Zotero 7: Word could not communicate with Zotero. Please ensure that Zotero is open and try again

This discussion was created from comments split from: Issues Zotero 7.
  • I tried Zotero 7 but I didn’t manage to let it play with Word. I reinstalled Zotero manually, deleted extensions.json, reinstalled the plugin, manually copied over Zotero.dotm, changed the languages of Zotero and Word to English, rebooted my computer: it still gives the same error, “Word could not communicate with Zotero. Please ensure that Zotero is open and try again”. The Word plugin also didn’t show up in Tools -> Add-ons.

    Eventually I gave up, reinstalled Zotero 6 and it works fine again.

    M1 MacBook Air, macOS 13.3.1, Word 16.73, Zotero 7 beta

    Note that my database was originally a Jurism database which I now use with Zotero, so this might be a possible reason?
  • Word and LibreOffice integration no longer show up in Tools → Add-ons in Zotero 7, so extensions.json is no longer relevant.

    Can you provide a Report ID after triggering this?
  • Yes, Report ID is 2006238858.
  • edited 10 days ago
    Can you provide a Debug ID for Zotero startup through reproducing the error, using the "Restart with Logging Enabled…" option?
  • @DutchZoteroUser: OK, we got a report of this from someone else. It looks like Zotero 7 is failing to display this error dialog:

    https://www.zotero.org/support/kb/mac_word_permissions_missing

    We'll fix the dialog, but this would happen if you declined to give it permission to control Word when prompted.
  • Thanks for the response. I did see this dialog the first time but I chose OK. Afterwards, it never showed up again.

    In macOS System Settings, Zotero is listed under Privacy -> Automation, but there’s only an option for “System Events”, not for “Microsoft Word”, as it was in Zotero 6.
  • edited 9 days ago
    In the latest beta, we've fixed the error dialog for this problem, but there's still an issue with Zotero 7 not properly triggering the permissions prompt.

    You should be able to work around this by installing the last Zotero 6 beta, triggering the permissions prompt with that, and then upgrading that to Zotero 7. Let us know if it works after that.

    Release and beta builds have a different macOS bundle identifier, so the system treats them as separate apps, but if you trigger the prompt with the Zotero 6 beta that permission should carry over to the Zotero 7 beta.
  • Thank you, that works indeed!
Sign In or Register to comment.