Zotero permissions error


eveŕy time I try opening Zotero I get this message:


Database upgrade error

Unix error 13 during operation remove on file /Users/kristiinatasane/Zotero/zotero.sqlite.1.bak (Permission denied)
(No stack trace)
From previous event:

What I have tried:
- updating Zotero, done
- Changing Zotero folder permissions from Read only to Read and Write
- Uninstalling and reinstalling Zotero

  • Same answer I gave you via email. This is a permissions error (usually from copying files from another computer), not a problem in Zotero itself, so really all we can tell you is that you need to make sure that all folders and files within the Zotero data directory are writable by your current user account.
  • For others, it turned out to be an easy fix: I changed the permissions on all the files to Read and Write, which unfortunately didn't solve the problem and took a ton of time. I finally just decided to do what Zotero tried to do automatically, which was deleting the .bak file named in the error message manually. It solved the problem and Zotero opened again no problem.
  • You certainly didn't need to do anything file by file. macOS lets you change permissions for all files and folders below a given folder at once ("Apply to enclosed items…" in the drop-down menu).
Sign In or Register to comment.