zotero empty storage library file despite existing sqlite backup file

Hello and thanks for your great software.
I have been using Zotero for more than a year synchronously on multiple devices without problem.

The problime arised when I tried to sync it on my new mac. Ever since somwething went wrong and even on my windows machine my library has gone empty. I went through some smilar threads on the forum, but none of the solutions worked yet.

Long story short: I can locate one sqilite.bak file in my windows machine with almost 45MB size. When I turn off syncing on the preferences and rename the zotero.sqlite.bak to zotero.sqlite, it loads my library locally on windows. But the moment I load the online library, either through web or enable synch, everything goes away again!

My zoter/storage/xxxxx/library is of size 99K which seems to be empty.

There should be some fix to let me update the library file (locally or on web account) from the existing zotero.sqlite.bak.

I would appreciate your help with it/.
  • edited May 15, 2023
    You deleted most items in your library a couple hours ago.

    Did you run Replace Online Library from a mostly empty library? Because that would certainly do it. This would absolutely not happen if you just set up a syncing on a new Mac and synced — that would just pull down your existing online library.

    In any case, to recover your data, see Restoring Your Zotero Data From a Backup and Overwriting Synced Changes. Any attachments will be gone, though if you were using Zotero Storage we could relink any files that had been previously uploaded.
  • Problem (ulmost) solved!
    Fortunately, I could restore from a rather recent zotero.sqlite.bak by running Replace Online Library!

Sign In or Register to comment.