Zotero Connector Error when using the "Save to Zotero (unAPI)" on a Wikipedia page.

edited April 26, 2023
When trying to save a Wikipedia page using the unAPI, there will be an error. The screenshots can be seen at https://i.imgur.com/RxjYjUV.png and https://i.imgur.com/SqSkDZc.png.

The Report ID is 845562226.
  • where (URL) are you seeing that? I don't believe Wikipedia has unAPI enabled (at least the English one doesn't).
  • On any Wikipedia page, for example, at https://en.wikipedia.org/wiki/Zotero, when I right click on the Zotero Connector's icon, it shows https://i.imgur.com/RxjYjUV.png
  • Yeah, definitely shouldn't be there and isn't for me. It should have "Save to Zotero (Wikipedia)" as the top option, followed by COinS.

    I'm a little puzzled by this -- I don't think we have every seen anyone getting the wrong translator on a page -- but you could try resetting translators under advanced --> files and folders in the Zotero preferences.
  • edited April 28, 2023
    I tried resetting translators as in the screenshot: https://i.imgur.com/4S9VpFh.png. But it doesn't change anything and I still see the same "Save to Zotero (unAPI)" as in https://i.imgur.com/RxjYjUV.png.

    Then I tried to update the translator as in https://i.imgur.com/vXKBTzu.png, but after clicking the "Update now" button, the text "Update now" was changed to "Error" shown on the button. So there seems to be some error/corruption in the translators in the database.

    So then I went back to the "advanced -> files and folders" tab as in https://i.imgur.com/4S9VpFh.png, and clicked on the "Check Database Integrity", and then it told me there are errors found and asked me to repair it online at https://www.zotero.org/utils/dbfix/.

    However, due to the confidential & sensitive nature of my Zotero database, I cannot upload it. So I tried opening the zotero.sqlite in some GUI tools such as DB Browser for SQLite (https://sqlitebrowser.org/), and run the integrity check by

    PRAGMA integrity_check;

    and it shows:

    *** in database main ***
    Multiple uses for byte 1977 of page 1791

    as in the screenshot: https://i.imgur.com/g32BRVf.png

    This looks like a leftover issue of database upgrade as in my previous issue https://forums.zotero.org/discussion/96811/, which is fixed in version 6.0.7 (see https://www.zotero.org/support/changelog#:~:text=Fixed target is undefined error upgrading from Zotero 4). But after upgrading to version 6.0.7 last year, I was too happy and relieved in exploring the new functionalities of Zotero 6 and forgot to check if there was any remaining issues/errors in the upgraded database. So it's likely that the upgraded database still has some minor errors/issues (not as severe as "database disk image is malformed" as in https://forums.zotero.org/discussion/49903/), which didn't pop up during the recent 1 year of my regular using of Zotero, until I clicked the "Check Database Integrity" button in Zotero preference today.

    Again, I cannot upload & repair the zotero.sqlite online due to its confidential & sensitive nature, so I was trying to follow in the instructions at https://www.zotero.org/utils/dbfix/manual to manually repair it. However, since I'm on Windows, I can't run the commands natively. But there are many GUI SQLite tools such as DB Browser for SQLite (https://sqlitebrowser.org/) and SQLiteStudio (https://sqlitestudio.pl/). So could you let me know how I can replicate the function of "sqlite3 zotero.sqlite .recover > dump.sql" command in these GUI SQLite tools to manually repair the database? Many thanks.
  • edited April 28, 2023
    Update: By using the sqlite-tools-win32-x86-3410200.zip downloaded from https://www.sqlite.org/download.html, I was able to manually repair the database following the steps in https://www.zotero.org/utils/dbfix/manual under Windows (manually rename zotero.sqlite to zotero.sqlite.old for step 2, or use ren or rename command in Windows command line).

    And after repair, when browsing a Wikipedia page, the available translators now include "Save to Zotero (Wikipedia)", followed by "Save to Zotero (COinS)". So this problem seems resolved. I guess the only corruption in my Zotero database was related to Translators, and it might be corrupted by some other add-ons or plugins such as Better-BibTeX, which might handle the translators and styles related stuffs in the Zotero database.
Sign In or Register to comment.