error when filling the author field

i run zotero 6.0.23 under macOs 13.2.1
when i fill the "author" field it happens that
i write the "last name"
then i tap "tab" to go the "first name" field,
at that point the cursor jumps to the "title translation" field
and if i click with the pointer on the "first name" field,
the focus remains in the "title translation" field
but in the "extra" field a string "title translation:" starts to appear,
and multiplies itself at every click in the "first name" field.

to stop all this and to be able to insert the first name i must click outside the info panel, on anything in the other panes; then i re-click on the "first name" field and it is now fillable; apparently it happens with any item (book, email, journal, report, ecc.) i choose.

  • edited April 12, 2023
    at that point the cursor jumps to the "title translation" field
    You're using a third-party plugin. You'll have to ask for help from the plugin developer.
  • Hi,
    I have the exact same problem (Zotero 6.0.23, Ubuntu 20.04): it comes from the plugin Zotero PDF Translate (I have the latest version to this date: 1.0.20). If you turn it off, everything works fine. I'll try to contact the developer (windingwind)
  • Hi again,
    Temporary fix: Go to Zotero EDIT > Preferences > Translate
    Untick Info Panel "Show Title Translation" and maybe "Show Abstract Translation".
    This fixed it for me ;-)
  • it works, thanks !
  • Thank you so much @mescande for this fix, this error was driving me crazy!
  • Thanks @mescande for the solution
    You may also need to untick the sidebar:autofocus option

    Best regards
  • Sorry for the long delay in fixing the bug.

    I've released pdf-translate 1.1.0-1, which is a beta for Zotero 7. This bug should be fixed after that version.

    The Z6 version is no longer maintained and thus will not fix this bug there.
Sign In or Register to comment.