Zotero – can't enter protected spaces into citation suffix

Hi Zotero Team,

this is my first post to this forum, so I hope that I follow all the rules.

I have a report of a minor bug. In the Zotero Cite dialog (the one which opens when I click on add/edit citation in Word), it is not possible to insert text with protected spaces.

Use case: I use Zotero for my doctoral thesis on law in Germany. Many sources are cited by so called Randnummern (marginal numbers), which I enter into the suffix, which then looks like "Rn. 18". Between the Rn. and the 18 I want to enter a protected space so that I do not get a footnote "Rn./LINEBREAK/18". For the prefix, there's a similar use case.

There might be a small bug preventing this. I tried it both on Windows and Mac and with copying over a protected space – neither produces the expected result.

Any help would be appreciated!

Kind regards,
  • Indeed not possible currently and likely a bug, yes.
    You could use one of the locators (such as "Note") and customize the citation style accordingly (i.e. define the short term for note as Rn. and putting a nbsp between locator label and locator, but that's the only option I can currently think of.
  • I can reproduce. We'll take a look.
  • Anything new on that? Would also be important for me. And I am pretty sure it used to work to enter protected space. On my Mac it was Shift + fn + blank.
  • Would be still be grateful, if someone could look at it :)
Sign In or Register to comment.