.ris file import does not import citations


I'm trying to import a .ris file into my Zotero and it is not working. After it is completed it says that 0 files were imported although I know for sure that the file has data in it.

Here is a sample of the text from the file:

TI - A cross-sectional study on assessment of perceived threat to cervical cancer using health belief model among women in a slum area of Kolkata
AU - Yadav, Akanksha
AU - Dobe, Madhumita
AU - Paul, Bobby
AU - Taklikar, Chandrashekhar
T2 - Journal of Education and Health Promotion
Despite the implementation of various cervical cancer preventive strategies by the Government of India, there is a scarcity of knowledge and consequent low utilization of cervical cancer screening services among women in India. This contributes to the burden of cervical cancer among Indian women. This study was conducted to assess perceived threat-regarding cervical cancer among women and to identify its explanatory factors in a slum area of Kolkata.

A cross-sectional study was conducted among 192 adult women from May to September 2019 in Kolkata. The multistage sampling technique was used using a structured schedule. Perceived threat to cervical cancer was measured using a composite score including perceived susceptibility and perceived severity constructs of the health belief model. Data were analyzed by descriptive statistics and multivariable logistic regression model using SPSS software version 16.

Overall, 22.9% of the participants had satisfactory levels of perceived threat to cervical cancer. Statistically significant association was found between unsatisfactory levels of perceived threat with reproductive age group (adjusted odds ratio [AOR] = 3.01; P = 0.036), education level up to primary (AOR = 2.89; P = 0.026), and unsatisfactory knowledge (AOR = 2.94; P < 0.001) among respondents. The multivariable regression model was of good fit.

The study population had very unsatisfactory levels of perceived threat to cervical cancer. Thus, to increase cervical cancer screening uptake among women, it is necessary to tailor robust behavior change communication campaigns to increase the perception of susceptibility and severity, thereby increasing the perception of threat of cervical cancer among women.
  • edited March 19, 2023
    The RIS file you provided doesn't conform to the RIS specification.

    Does your RIS file end below the conclusion section of the abstract. It is missing important details: volume (VL), issue (IS), pagination (SP/EP), publication year (PY), ER to indicate the end of a record (although Zotero may tolerate that omission), ISSN (SN), DOI number (DO), etc. Someone else will need to comment about the acceptability of the new-line breaks in the abstract (I don't know if that is handled in Zotero) but empty lines are not permitted in the RIS standard.
  • edited March 19, 2023
    No it does include these information but because of the character limit I couldn't include them. (see below)

    I am using Zotero on a Mac if that is relevant. I used to use Mendeley before and I tried extracting the file into it and it worked.

    DA - 2022/04/28/
    PY - 2022
    DO - 10.4103/jehp.jehp_392_21
    DP - PubMed Central
    VL - 11
    SP - 124
    J2 - J Educ Health Promot
    SN - 2277-9531
    UR - https://www.ncbi.nlm.nih.gov/pmc/articles/PMC9170203/
    Y2 - 2023/02/24/04:42:19
    L1 - https://www.ncbi.nlm.nih.gov/pmc/articles/PMC9170203/pdf/JEHP-11-124.pdf
    L2 - https://www.ncbi.nlm.nih.gov/pmc/articles/PMC9170203/
    ER -
  • The RIS (the two parts together) do import just fine for me.
    Could we get a debug ID for the failed import from Zotero, please? https://www.zotero.org/support/debug_output

    (FWIW, we'd generally recommend using the Save to Zoteor button, .nbib or just the PMID via add-by idenfier when importing from Pubmed, which, among other advantages, will get you the PMID)
  • edited March 21, 2023
    It does not give any error messages but I will try to post the log output in a second. It just says "0 items imported"
  • Don't post the output -- we'd want the debug ID as indicated.
  • Here it is:


    Thank you.
  • @dstillman -- could you take a look?
  • @Muhammad_Hmi: Looks like you have Better BibTeX translators that weren't properly uninstalled and possibly other problems. Reset your translators from the Advanced → Files and Folders pane of the Zotero preferences.
  • Works perfectly. Thank you so much!
  • edited March 22, 2023
    Since we had another report of this, did you have BBT installed on this computer previously? Did you recently copy your Zotero data directory from another computer where BBT was installed?
  • edited March 22, 2023
    I recently switched from a Windows PC to a Mac and this is the first time that I tried to import anything form a .bib/.ris/.rdf file. I transferred everything using the TimeMachine and copied all the info for my Zotero.

    I don't recall having BBT installed on my Mac but I did install everything related to LaTeX because I do use that. I don't know if this is relevant or not.
  • OK, so this is likely just from transferring the data directory from the other computer, and you had BBT and its translators installed on that computer. (The BBT JSON translator is from 2023-01-27, so it's recent.)

    @emilianoeheyns: I'm not sure what's going on here, but for some reason RIS wasn't detecting at all in these cases. I'd never really thought about the situation where people transfer a data directory with BBT translators without reinstalling BBT, but it would certainly cause problems in general. We could maybe consider preventing loading of the BBT translators when BBT isn't loaded, though it'd be good to figure out how to reproduce this. I guess if someone reports this again we can ask for a ZIP of the translators directory before resetting.
  • edited March 22, 2023
    Still not clear to me how ris import could be affected under this scenario. I can understand bibtex import being affected, but not literally anything else. I haven't been able to reproduce this.

    Ignoring (or removing) the bbt translators when bbt is not installed might help, but I don't understand how in this case.
Sign In or Register to comment.