Text-to-speech function not working on iPad

iPad Model: iPad Pro (12,9 inch, 5. generation)
Software version: 15.7.1
Same issue in the forum: https://forums.zotero.org/discussion/comment/414838#Comment_414838

Problem statement:
If I select some text in a PDF and want it to be read out loud, the function "Speak..." does not work as are the functions " Speak Sentence" and "Spell". Instead thin vertical grey lines appear.

Workaround 1 - But low quality audio afterwards - so no real solution:
Disable Speak Selection in the Settings: Accessibility -> Spoken Content -> Speak Selection

Workaround 2 - But PDF is not shown in original format - so no real solution:
Click on the symbol with an "A and the horizontal lines" on the top left

Possible solution:
I had exactly the same issue (same grey lines appearing) with the PDF annotation app from PSPDFKit (probably the most advanced company with an specialization in "displaying, annotating and editing PDFs on iOS, Android, Windows, Electron and the Web").

The workaround here was to change the the page transition. They have the same page transitions as Zotero does (Jump and Continuous), but they have one additional transition, which looks like you would thumb through a book and only with the latter the speech function worked with Apple's "Spoken Content".

I'm also not a great fan of this workaround, as I like to see the things (e.g. graphs) on the next page.

What I have tried to solve the problem mentioned under "Problem statement":

I have tried out everything mentioned in this post (e.g. check text layer): https://forums.zotero.org/discussion/93144/text-to-speech-doesn-t-work-after-recent-ipad-update

I have tried out all possible combinations of settings (Page Transition, Page Mode, Scroll Direction, Page Fitting, Appearance and Allow device to sleep) but none of them solved the issue.
Sign In or Register to comment.