Transfer Documents from Group Library

I am trying to transfer documents from a group library that I don't own to another library. When I transfer and then try to open the attached PDF, I get the following error: "The attached file could not be found at the following path:... It may have been moved or deleted outside of Zotero..."

I haven't had this error for the group libraries that I own and transfer.

Wondering if there's a way around this issue?
  • Are you sure you can open the file in question locally in the original library?
  • Can you delete the item in the target library and provide a Debug ID for 1) opening the file in the source library, 2) dragging the item to the target library, and 3) trying to open the file in the target library unsuccessfully?
  • Note that if you have Zotero set to download files as needed in the Sync settings, the file won't exist locally until you try to open it, and dragging before then wouldn't work. (This is arguably a bug that we need to fix, but it's how it works now.) But opening the file in the source library immediately after would still work because it would actually download the file at that point.
  • You didn't delete the item in the target library before dragging. You have to actually delete it from the library root (i.e., so that it's in the trash), not just remove it from the collection you're dragging to. Otherwise when you drag to the collection from the other library it just adds the existing item to that collection.

    This is almost certainly just the issue I describe above — that when you first did this cross-library drag, the file didn't hadn't yet been downloaded in the source library. If you actually move the item in the target library to the trash and repeat the drag, it should work.
  • It worked now! Thanks for the help.
Sign In or Register to comment.