Zotero 6.0 for Linux Mint Tessa 64-Bit?

I urgently need to update my Zotero to 6.0 and was a little shocked that it is (for Linux) only available for 32 bit. I use Linux Mint 19.1 Tessa, Cinnamon 4.0.8, 64 bit. Will there be a 64 bit version or an alternative for me and maybe other Zotero Users?

Thanks in advance!

  • Not sure what you're talking about. We've always offered a 64-bit Linux version.
  • Thank you for the message. I had made two posts at different times, to which you kindly responded. Perhaps you can delete the first one (title: 579826451) because the current status is as follows:

    - I exported my old Zotero library including attachments
    - Then I uninstalled my Zotero version to install the Zotero 6 version
    - On the download page of the homepage there is only a link to Linux 32-bit, see https://www.zotero.org/download/

    I could send you a screenshot if neccesary
  • You can take a screenshot, upload it somewhere (Google Drive, Dropbox, etc.), and provide a link here. But the large download button should be the 64-bit version on most Linux systems.
  • Thank you, I have solved the problem. I used an unofficial PPA. I have no explanation why the manual installation did not work. The only thing that irritated me on the download page was that only the 32-bit version was listed. With the previous Zotero version, the 32-bit and 64-bit versions were listed.

    Thanks for your time and help!
  • edited March 14, 2023
    Again, you're mistaken. The download page offers a 64-bit version. The 32-bit version is listed under "Other platforms".
  • I think I didn't realise that the big download button was for the 64-bit version. I mean, both used to be listed under "Other Platforms", but that doesn't matter now.

    Nevertheless, the link to the screenshot https://drive.google.com/file/d/1n4suWRL_CyYJ20uTaEVfMhKc6o3osYfC/view?usp=share_link
  • Do you actually mean a PPA, by the way, or the .deb from https://github.com/retorquere/zotero-deb/? The deb is fine (in fact recommended) to use, but I'm not aware of a PPA that's updated reliably enough to recommend using it.
  • edited March 14, 2023
    I did it twice with the following commands and it worked quite well:

    wget -qO- https://raw.githubusercontent.com/retorquere/zotero-deb/master/install.sh | sudo bash

    sudo apt update
    sudo apt install zotero

    I can't say whether I would recommend it because of that. I cannot evaluate the security risk with regard to code from untested sources.
  • Right, that's not a PPA, but that's fine to use -- the maintainer is a long-term contributor to Zotero and the .deb just packs the official code.
Sign In or Register to comment.