DOI and doesn't save?

Just in the past day or so, on some webpages (and even PDFs), the Zotero connector icon in Chrome (pinned) shows the DOI icon (paper with horizontal lines) instead of the generic webpage or PDF icon.

When I click on the Zotero icon (or use the Ctrl shift s hotkey), it tries to do "Save to Zotero (DOI)" but NOTHING happens, whether it's a webpage or PDF.

I have to rightlick the Zotero icon, choose Save to Zotero, then Save to Zotero (Webpage with snapshot) or, when it's a PDF, Save to Zotero (PDF). This requires 3 steps per webpage/PDF instead of just Ctrl shift s.

It's only some webpages/PDFs like and - not all of them. But this issue is significantly increasing the time and effort needed to save those webpages/PDFs.

Can this be fixed please, is there a shortcut to let me save to webpage/pdf in one step and not three? E.g. can I disable DOI which I never use?

  • Most peculiar. Works on some sites with DOI icon, but not others! Works in Firefox even with the "iffy" sites.
  • edited March 11, 2023
    There's two separate issues:
    1) On webpages with DOIs, you'll always get Save to Zotero (DOI) by default. I think Zotero is planning to fine-tune that behavior, but it *will*, in most cases, give you better metadata. Edit: EU pages are an exception here because they use custom DOIs without metadata. You'd have to use the right-click workaround there for now.
    2) On PDFs, you should virtually always get the PDF icon and never get Save using DOI (you will for a very few sites get the article icon, but using a custom script -- like Save to Zotero (arXiv), which will get the PDF and, again, better metadata.) If you don't get the PDF icon, something isn't working right. Typically just reloading fixes that. I don't know if that's possible to troubleshoot.

    And no, you can't just disable the DOI option.
  • Thanks for your quick reply.

    The problem is that Save to Zotero (DOI) isn't doing anything at all. It's just not saving.

    I have to rightclick and choose webpage with snapshot to save anything.

    Same with PDFs. And it's the same few sites that that's an issue, even after reloading.
  • Can you provide an example URL where this is happening and a Debug ID for reloading the page and clicking the button?
  • I have had two customers reporting similar problems today. I'm trying to get some webpages, but at the moment just have this one:

    It has no SSL certificate. The customer on Firefox and me on Chrome both had the Connector fail to put anything into Zotero, though it said it was capturing it in the Connector window. When I tried it in Edge, I was able to get it to come over.
  • My Debug number is D1462281826. The Connector window, by the way, never disappears on the website from which I called it.
  • Thanks

    as per above is actually a better example that doesn't require dealing with the broken cert

    This is a regression introduced by

    The way you coded this, an empty array for the DOI search (i.e. no DOI on the page) will result in detectWeb --> "journalArticle"
  • edited March 12, 2023
    I just pushed a fix.

    For those affected, your Zotero Connector should auto-update within 24 hours, or you can update manually by clicking Update Translators in the Advanced pane of the Zotero Connector preferences (accessed by right-click on the save button).

    Sorry for the trouble here.
  • Thank you for the rapid fix!
  • Thank you very much @adamsmith and @dstillman for the quick action even at the weekend, it's working now!
  • I'm still having this problem in Edge and Chrome - clicking the Zotero Connector button does nothing.

    However, if I right-click the connector==>Save to Zotero==>Save to Zotero (PDF), the PDF is imported as expected.

    I reinstalled the connector in Chrome and tried updating the translators as suggested above. The problem did not resolve. The page I'm having a problem with is here:

    Interestingly, the link to the Springer page (rather than the PDF) imports into Zotero as intended:

    OS: Windows 11
    Zotero version: 6.0.22
    Connector version: 5.0.107
  • edited March 13, 2023
    @jeremymatt: If you're saying you still see "Save to Zotero (DOI)" when you hover over the save icon on all pages without a dedicated translator, you're still on the broken translator. Reset translators from the Advanced → Files and Folders pane of the Zotero preferences, and then do the same from the Zotero Connector preferences.
Sign In or Register to comment.