Zotero experienced an error updating your document

Step to repro this problem:
1. create a new doc in Word
2. Type some words
3. Add/Edit Citation
4. Choose citation style
5. Pop-up window with "Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?"
  • Can you provide a Report ID to start?

    What exact Word version?
  • Thanks @dstillman
    Report ID: 287476452
    Word for Mac version: 16.70
  • edited March 4, 2023
    [JavaScript Error: "Field reference lost @[insertFieldRaw:document.m:1772]" {file: "file:///Applications/Zotero.app/Contents/Resources/extensions/zoteroMacWordIntegration@zotero.org/components/zoteroMacWordIntegration.js" line: 266}]
    Is this a new problem? When's the last time you used the plugin successfully on this computer?

    Start by making sure you have the latest version of the plugin: go to your Word Startup folder, delete Zotero.dotm, restart Word to make sure it's gone, and then reinstall the plugin from the Cite → Word Processors pane of the Zotero settings.
  • I installed Zotero today for the first time. I have never been successful.
    I tried to delete the Zotero.dotm and reinstall the plugin several times, but it didn't work.
  • edited March 4, 2023
    Have you tried restarting your computer? Do you have other Word plugins installed? Does it happen with any citation style? Any item? Are you in some unusual Word mode? This is a pretty unusual error to get in a new, empty document.
  • 1. Restarted
    2. How to check if other Word plugins are installed? There is only Zotero.dotm in Global Templates and Add-ins.
    3. Normal Word mode
    4. You reminded me. I tried some of the styles. Chicago Manual of Style 17th edition note works fine.
  • Which styles don't work and which do?
  • Both of APA 7th edition and 6th edition didn't work. I just found if I add a citation by using the Chicago Manual of Style 17th edition note, then change it to APA 7th edition, it works.
  • OK, @adomasven will need to take a look.
  • I selected the sentence before adding a citation. Is it the problem?
  • Yes. Don't do that. Just put the cursor where you want the citation.
  • Thank you for the prompt response! Great job Zotero!
  • @swat318 Testing this I cannot seem to reproduce it. Does it only happen if you select text in the document? Can you create a video recording of this issue occurring in a new document, upload it somewhere (like Dropbox) and post a link here?
  • @swat318: I can reproduce this by selecting past the last line of a document and then using Add/Edit Citation. If that's what you're seeing, no need for any other info.
  • @swat318: We've fixed this for the next release — thanks for reporting.
  • edited 22 days ago
    Same fatal, catastrophic problem on a PC, v. 6.0.36
  • Report ID 921742018

    Open Saved File
    Attempt any Zotero function (add/edit)
    Error "Zotero experienced an error updating your document."

    Copy->Paste into new file
    Attempt any Zotero function (add/edit)
    Works fine
    Save File
    Open Saved File
    Attempt any Zotero function (add/edit)
    Error "Zotero experienced an error updating your document."
  • Not the same issue -- does sound like a broken citation. Have you run through 11 here? https://www.zotero.org/support/kb/debugging_broken_documents
  • edited 21 days ago
    If that were the issue, why would it work on a new doc, but not on a saved one? Identical text and cites. With or without a Bib. Even after a Refresh, the pasted doc works. No errors.
  • I'm not entirely sure, but I do suspect something either gets written to the file in a weird way and/or refreshed after saving.
    Someone can look at your report ID, but unless you can replicate this with saving a completely fresh document with just a couple of citations, this is something specific about the document so the linked instructions apply.
Sign In or Register to comment.