Solved: Dialogs appear blank on macOS

edited February 19, 2023
Dialog windows appear blank. Their content is there but invisible (I can still blindly type and confirm or abort using the enter or escape key). All I can see is the white background.

This happens consistently.

Examples of affected dialogs are:
- name entry for newly created group
- name entry for group when renaming
- confirmation dialog for deletion of an item

My current OS is Ventura 13.2 (22D49) running on an M1 MacBook pro.
The current Zotero version is 6.0.21.
But this has been going on at least since beginning of January 2023 when I installed Zotero after not using it for a while.
  • Are you using Dark Mode on your computer? Have you previously run any sort of third-party utility that affects Dark Mode?

    Try closing Zotero, opening Terminal (via Spotlight), pasting in this command, and pressing Return:

    defaults delete -g NSRequiresAquaSystemAppearance
  • Thanks, that did the trick.

    I used to use Boring Old Menu Bar (an app that gets rid of the obnoxious translucency of the menu bar) for a while. I can only guess and assume that that app changed the setting and that the setting stuck after I deleted the app.

    Thanks a lot!
  • Hi dstillman,
    Thank you for posting this solution! I have the same issue, but on my computer the command is returning "Domain (kCFPreferencesAnyApplication) no found. Defaults have not been changed". Zotero dialogs are still blank. Is there anything else I could try? I really appreciate your help!
  • Hi @dstillman, I apologise for my hasty reply. After posting my previous comment I copied the command rather than typing it in and it worked. Thank you!
Sign In or Register to comment.