Zotero puts dash - after author when renaming


I set up zotfile to rename like {%a}{ %y}{ - %t}. The preview shows the correct format then. However, when I link a file in zotero and then right click to rename the file it adds a dash like Author - Year - Title (while it should be Author Year - Title).

Does someone how to tell zotero to use the format I defined in zotfile?

Kind regards
  • You are selecting Zotero’s native rename option from the right click menu. Select the rename option from the Zotfile part of the right click menu to use Zotfile’s rules. Note that if all you are using are author, title, and year, you can also customize Zotero’s native renaming by opening preferences to the Advanced pane, clicking Config Editor, searching for attachmentRenameFormatString and setting the format as desired
  • Hi, thank you for your reply. In the meantime I found the config file under advanced already and I was able to find the right entry by searching for rename. There you can indeed see the dash - and remove it.

    I'm curious about your other mentioned option. Where do I find the zotfile part you are referring to? When I right-click an attachment I cannot see a zotfile menu.
  • Oh, I think you mean the Manage attachment submenu. That works like charme indeed.
  • Yep — sorry, that’s the Zotfile attachment menu, Manage Attachment
Sign In or Register to comment.