Import timeout with Chrome Connector in Windows

Hi. I'm trying to help a student who's having trouble with the Zotero Connector in Chrome. I've been through a few exercises and am now wondering if the issue lies with Windows or Chrome itself.

I've confirmed that the student is unable to import items that are importing OK for me, and that we're running the same versions of the various components:

- Zotero (6.0.20)
- Chrome (109.0.5414.75)
- Zotero Connector for Chrome (5.0.103).

All attempts to save using the Connector are appearing to result in a timeout error. The article title appears in greyed-out text, and then a few seconds later an error message appears. ('An error occurred while saving this item').

If we enable logging in the plugin, we don't see any warning or error notices - but there is some content in the Report Errors section of the preferences window. These tend to follow the same pattern for multiple items - here's a typical example:

-----

[JavaScript Error: "HTTP GET https://eutils.ncbi.nlm.nih.gov/entrez/eutils/efetch.fcgi?db=pmc&retmode=xml&id=7099199 failed with status code 0" {file: "chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/zotero.js" line: 335}]

[JavaScript Error: "HTTP request to http://127.0.0.1:23119/connector/saveItems has timed out after 15000ms" {file: "chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/zotero.js" line: 335}]

[JavaScript Error: "Error: HTTP request to http://127.0.0.1:23119/connector/saveItems has timed out after 15000ms
at chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/messaging_inject.js:79:17
at async Zotero.Translate.ItemSaver.saveItems (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/translate_item.js:128:15)" {file: "[object Object]"}]

-----

The 127.0.0.1 URLs do respond immediately if pasted into their own tabs, so the local server itself seems to be running.

Dragging PDFs into Zotero Desktop and importing DOIs using the magic wand tool both work as expected.

The student somtimes gets an error message from the plugin telling him to update translators, which he has tried in the plugin preferences window, but this hasn't made a difference. He has also removed and reinsalled the Zotero plugin, and when we spoke I asked him to try using the Edge plugin, which also timed out.

Could this be an issue related to Windows in some way? It appears that the plugin and Zotero Desktop are both doing their job, but are unable to communicate for some reason. The fact I'm able to import items using the same versions of Chrome, Zotero, and the Connector makes me doubt this is something like Manifest V3 starting to surface.

I also note that the first entry in the error report above seems to suggest the Connector cannot reach the XML file decribing the article (https://eutils.ncbi.nlm.nih.gov/entrez/eutils/efetch.fcgi?db=pmc&retmode=xml&id=7099199), though this does load OK in a new tab for both the student and me.

Any ideas on where to go or what to try next would be much appreciated. Many thanks.
  • Can you provide a Debug ID from the Zotero app for a save attempt that times out? (Be sure to reload the page before saving.)
  • Hi - many thanks for the reply. I've asked the student to submit a report and the ID should be D1535156023.
  • That's from the Zotero Connector, not from the Zotero app.
  • Apologies, that was my error. A report should now be submitted with the ID D805088616.

    The student has also reported a change in behaviour over the weekend - they're still seeing the error messages when importing, but the metadata now seems to be appearing in Zotero afterwards despite the message (this definitely wasn't the case last week, as we went through the problem on a video call). However, PDFs are not appearing - but I don't know if this is an issue with access conditions on the sites being used - I can try to check this if required.

    Many thanks again for the help.
  • Well, this is a different site, but here they're just trying to save from the PDF viewer URL. They should always save from the abstract page. A PDF URL works on a small number of sites, but often it's not possible for us to support that.

    (This is also the point of the toolbar button icon. On the PDF page, you can see that it's just a webpage icon, and it says "Embedded Metadata" — a generic translator — when hovering over it. On the actual article page, you'll see a journal article icon, and it will say "ACS Publications" in the tooltip, the same as on any supported site.)
  • Ah, I think this may have been a poor choice of site when saving this time round - I did confirm via a video call that the error was appearing on journal abstract pages, websites (a BBC news story), and also on a page of results from our library search tool. In all cases the title(s) of the articles did appear in the Connector pop-up (in the intially greyed out text), but the Connector would time out several seconds later.

    I'll see if I can meet with the student again to ensure the debug uses a suitable page - if you have an example that would suit you best, please let me know and we can use that.
  • Any site is fine. The point is just that the above Debug ID shows a successful save to Zotero, even if it's only on a page where one shouldn't expect high-quality metadata or a PDF.
  • edited 7 days ago
    Hi again - I aksed the student to save the record at https://jcom.sissa.it/archive/21/07/JCOM_2107_2022_A03, as I knew this would be an OA article with the PDF accessible. In my profile this did indeed save both metadata and PDF.

    In the student's case Zotero is now saving the metadata but failing to save the PDF, and is still showing the error message when saving. I have confirmed that their instance of Zotero is set to save PDFs where possible.

    The Debug ID for this is D176277395. If this throws any light on the issue, any advice is much appreciated, as always. Many thanks.
  • That's actually very strange debug output.

    Can you ask them to provide another Debug ID for Zotero startup through the first time reproducing this, using the "Restart with Logging Enabled…" option? They should wait a couple minutes after the save attempt before submitting.
  • Hi again - in classic form, the issue seems to have resolved itself today. The user has been through the restart > debug process, and found that both records and PDFs were saving as usual with no error messages. They do note that they had a Chrome update, which they applied before my email arrived, so perhaps this was a factor. They've also tried saving several additional records under regular conditions, which has worked fine.

    They have submitted the debug ID, in case it contains anything of use: D1397782711. But it does appear that Zotero has returned to normal for them, so please consider the problem resolved from our perspective. Many thanks again for your help with this issue.
  • Chrome wouldn't have affected it, but I'd guess some previous save operation had just frozen in some weird state. Not anything we've seen before, but restarting was likely enough to fix it.
  • Thanks. Is restarting with logging enabled something to work into initial triage? Does it do more than a simple close / restart? I'm wondering if it might have resolved the problem during our initial meeting, though hopefully this'll prove to be a one-off.
  • edited 5 days ago
    No, this has nothing to do with the logging option, or even with Zotero specifically. Restarting any app or your computer is just always the first thing to try if you’re experiencing a problem.
  • OK, thanks - I think all available restarts had been attempted, but of course it can be tricky to confirm this on a video call. This has been very helpful, though - I'll certainly try to collect Debug IDs before raising any future issues (one issue in several years of use is pretty good going).
Sign In or Register to comment.