Zotero connector automatic proxy redirection not working

Zotero ver.6.0.19-beta.14+9d2c7d44f.
Report ID: 1704361374

When I open websites for which I have set up automatic proxy redirection via Zotero connector, my browser (Google chrome) hangs and cannot open the website.

When I check Zotero settings, I see the following error message repeated many many times:

[JavaScript Error: "Invalid proxy %h/%p: TypeError: Cannot read properties of null (reading '1')" {file: "chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/zotero.js" line: 335}]

Can you help me with resolving this issue? I can provide more info as necessary. Thanks!
  • Could you go into Zotero Connector Preferences -> Advanced -> Config Editor, copy the contents of the proxies.proxies field and send it to support@zotero.org with a link to this thread?
  • Thanks for taking a look, will do!

    To add a little bit more context, my proxy is via my university library, and it used to work until recently.
    I've noticed that the error shows up when I'm connected to the university wifi, and doesn't show up when I'm connected to some other wifi. Could this be a hint for the issue?
  • Hi, just want to add that I'm having this exact same problem. Like tomosoeoc, it only happens when I'm on my university library's wifi.
  • @Mark2k2 could you submit a Report ID?

    @tomosoeoc If you go into Zotero Connector Preferences -> Proxies, select your university proxy, copy the Proxied URL Scheme, paste it into Login URL Scheme field, then restart your browser, do you still encounter the same bug? Make a copy of Login URL Scheme field before overwriting, since there is no automatic way to restore it after this.
  • Hi @adomasven,

    Sorry for the late reply! Didn't notice your message for a bit.
    My Zotero connector plugin on chrome seemed to crash, and I needed to "Repair" it, so I needed to set my proxy up from scratch. This seemed to have changed the behavior a little bit, which I document below.

    1. I put %h.libproxy.university-name.edu/%p in the Proxied URL Scheme, and then used my university's proxy to access a journal article on a non-university WiFi. This worked, and it automatically generated Login URL Scheme field that looks like https://libproxy.university-name.edu/login?qurl=%u. In addition, the journal website was added to known hosts, and when I visited the website again, it redirected me to the proxied URL automatically.

    2. I connected to the university WiFi and tried connecting to the journal website again. The browser hanged, and I could not reach the journal website. Interestingly, this does not seem to generate any error message.

    3. I tried what you suggested, and pasted the content of the Proxied URL SCheme to the Login URL Scheme field. They now both look like %h.libproxy.university-name.edu/%p. When I used my university WiFi, it did not prevent me from visiting the journal website. On the other hand, when I was using non-university WiFi, the automatica redirection no longer worked, and I needed to manually activate my university proxy.

    To summarize, I could not find a configuration where 1) my university WiFi doesn't error, and 2) I can use automatic redirection.
  • Can you test this instead by removing Login URL Scheme in the preferences, such that only Proxied URL Scheme is present? Do not modify the Poxied URL Scheme. Are you sure you had this proxy setup with the Zotero Connector in the past and it worked when connected to your university wifi?
Sign In or Register to comment.