Wrong metadata retrieved for PDF

This discussion was created from comments split from: How to fix wrong metadata.
  • I'm having a problem with an item that pulls the wrong metadata. It is a pdf of somebody's lecture notes. The notes reference an arxiv article that one should read, and zotero pulls the metadata for the arxiv article (which I already have in my collection). It renames the pdf for that article. I do not see an "undo retrieve metadata" option when I right click, even seconds after it retrieves it. I've successfully pulled it out of the parent item so I can make a new parent item, but I cannot seem to rename the file in the Zotero window, it still shows as the name of the arxiv article. I tried "show file" and then pasting in the former name, but Zotero just renames it.

    The item I'm having a problem with is here:
    https://muellergroup.lassp.cornell.edu/bt2020chap1.pdf

    I'm using Zotero 6.0.19.
  • edited 23 days ago
    (Please start new threads for new issues. I've moved this to a new thread.)

    "Undo Retrieve Metadata" appears on the parent item, not the PDF.

    You can manually rename attachment items and their files by clicking on the attachment title in the right-hand pane, but it's easiest to just right-click on the attachment item and choose Rename File from Parent Metadata.

    As for the wrong metadata, we'll see if there's anything we can do about that. It's a bit tricky — there wouldn't be other metadata to retrieve for that PDF, there's an identifier on the first page, and the resolved title of that identifier is also on the page. But it's possible we could reject that identifier based on the much larger title on the page (though even there, it has some of the same words…).
  • Thanks, Dan. My immediate problem is solved, but I do have one question remaining.

    I just moved the item to the trash and then re-added it to Zotero. It downloaded as bt2020chap1.pdf. Then the metadata was retrieved and filename got changed. I right clicked on the parent item that got created. There is definitely no "Undo Retrieve Metadata". The options are: Open pdf, open pdf in new window, view online, show file, show in library, add note, add note from annotations, add attachment, add to collection, remove item from collection, duplicate item, move item to trash, export item, create bibliography from item, generate report from item, better bibtex. Is this the menu you think "undo" should appear on, or do I have the wrong menu? For future reference I would like to be able to find it.

    As for renaming the file: If I left (regular) click on the file itself, the pane to the right shows the filename twice. Once at the top, and once after the word "filename:" I had been trying to change it by clicking on the second one, after the word filename, and that one you cannot click on and change. Now I have clicked on the filename at the very top and successfully changed that. The second one still said the filename is Orus - 2014 - ...etc. So I tried changing it manually using "show file" and changing the filename directly in the computer filesystem. That was a mistake, because then zotero could not find the file. So I sent that item to the trash, downloaded it again, dragged it out of the auto-created parent item, manually created a new parent item with the name bt2020chap1, and chose "rename file from parent metadata". That successfully solved my problem. Also, I'll just note for posterity that in order to get zotero to download the file again to make a new item after sending my item to the trash, I needed to reload the pdf. If I just "add to zotero" from my browser without hitting reload first, it says that it is adding to zotero, but nothing actually shows up in zotero, probably because some system recognizes we just downloaded this file and don't need to download it again.

    I appreciate your help! And I love Zotero, and am enjoying the new reader/annotation mode.

    Emily
  • edited 21 days ago
    Sorry, it looks like "Undo Retrieve Metadata" isn't shown if there are multiple child items — as part of a test to make sure the item hasn't been further modified — but here a child note is also created. We'll fix that.
    The second one still said the filename is Orus - 2014 - ...etc.
    "Rename associated file" has to be checked if you want to change the filename too. (But again, manual renaming via that dialog is usually not the best way to do it.)
    If I just "add to zotero" from my browser without hitting reload first, it says that it is adding to zotero, but nothing actually shows up in zotero
    It's not saying that it's saving again — it's just reopening the save popup exactly as it was in case it closed before you chose the collection you want to save to or added tags. There's generally no reason anyone would want to create a duplicate immediately, so it doesn't resave unless you reload the page.
Sign In or Register to comment.