Fehler 1457837129

Hallo, ich nutze Zotero schon viele Jahre ohne Probleme. Seit gestern erhalte ich permanent die Fehlermeldung "Zotero Integrationsfehler - Ein Fehler ist beim Update Ihres Dokuments aufgetreten". Was kann ich tun, um schnell wieder arbeiten zu können?

Danke
Claudia
  • Does it work in a new, empty document?

    If it works in a new, empty document and you're only having a problem with a specific existing document, see Troubleshooting Errors in Word Processor Documents, which is linked from that error dialog.
  • It does work in an empty document, but only once. So if I want to make the second citation in the document, I receive the same error.
  • Are you saving the document? Are you saving it in OneDrive? If so, see the linked page.
  • I am saving the document on my computer, but the "origin" of the document is a download from dropbox. Can that be a problem?
  • edited 24 days ago
    I'm not sure what you mean by that. I'm asking about the new, empty document where you can reproduce this.
  • i only save it on my computer if thats what you mean. No Onedrive.
  • edited 24 days ago
    What are the exact steps to reproduce this, including the steps of starting up Word and starting a new, empty document?
  • I now started a completely new document in Word (just opened word from my Desktop) an made some citations in the empty document for testing. - it worked without errors
    then I copied an pasted the text I work on to a new document and saved it, first citation worked, second did not work.
  • edited 24 days ago
    Right, but then that's no longer a new document that you're creating from scratch — that's a copy of your existing document. So follow the Troubleshooting Errors in Word Processor Documents steps through to the end.
  • Restart both Zotero and your word processor. - DID SO

    Make sure you're using the latest versions of Zotero and your word processor. - IS INSTALLED

    While troubleshooting, disable the Track Changes feature in Word/LibreOffice, as it can have complicated effects when working with Zotero. If Track Changes is enabled when you insert or modify a Zotero citation, it may mark many or all of the Zotero citations in your document as changed or cause field codes to be displayed. On rare occasions, Track Changes may cause Zotero to think a citation is corrupted. If you had Track Changes enabled previously, try accepting all changes to see if that resolves the issue. - WASNT ACTIVATED

    Check for citations in image captions. Zotero won't let you insert them, but if you copied a citation to a caption that's most likely the source of the problem. Delete it.
    Try copying and pasting the document content into a new document (or using File → “Make a copy” in Google Docs) to see if the problem goes away. You may need to click the “Set Document Preferences” button before your old citations will be recognized. - NO CAPTIONS USED; I COPIED AND PASTED THE TEXT AND THE DOCUMENT ITSELF; STILL NOT WORKING; I CLICKED "SET DOCUMENT PREFERENCES", ALSO ERROR "ZOTERO INTEGRATIONSFEHLER-EIN FEHLER IST BEIM UPDATE IHRES DOKUMENTS AUFGETRETEN"

    Make a copy of your document — by duplicating the file itself, not by copying and pasting the content — to use for debugging. - DIDNT WORK


    If using OneDrive on Windows, save the copy of the document to your local hard drive, or try renaming the file to remove any spaces in the filename. OneDrive is known to interfere with the plugin for some people. If this fixes the problem for you, you can help us debug this conflict by posting to the Zotero Forums.
    Open the copied file and check if you get the error after switching to a different bibliography style. - NO ONEDRIVE USED

    If the document has a bibliography, delete it and check if you still get the error.
    While debugging, if you are using Fields mode in Word or Reference Marks mode in LibreOffice, it may help to display field codes rather than formatted text. To do this, press Alt/Option-F9 (or Alt/Option-Fn-F9) in Word or Ctrl-F9 in LibreOffice.
    - ERASED BIBLIOGRAPHY, THAT WANST THE PROBLEM EITHER

    Isolate the problematic citations. Delete half of the document at a time and see if the error still occurs. If not, use Undo to restore the deleted section and then try deleting the other half. Repeat the halving process on the section that fails, or pick one at random if both do. Continue this until you find the smallest possible section, ideally with a single citation, that must be present for the problem to occur. Remove the isolated citations from the original document and the problem should go away (unless there are multiple broken citations, in which case you'll need to repeat the process). Unless the error still occurs if you completely clear the contents of the document, this final step will by definition identify the problem. - COPIED PARTS OF DOCUMENT, ERROR OCCURS IN ALL OF THEM
  • Is it possible to send the document?
  • edited 24 days ago
    COPIED PARTS OF DOCUMENT, ERROR OCCURS IN ALL OF THEM
    That's not what it says to do, though. First, you're supposed to be operating on the full copy of the file itself that you created in Step 6, not content that you've copied in. And then it describes a different, very specific process, not just copying "parts" of the document. And see the last sentence:
    Unless the error still occurs if you completely clear the contents of the document, this final step will by definition identify the problem.
    Did you do that? What happens when clear the entire contents?
    Is it possible to send the document?
    Yes, the page says to send an excerpt of the document in which the problem occurs to support@zotero.org with a link to your forum thread.
  • I wanted to note that I had the same problem when working from a Word document directly from Onedrive. I saved a copy to my local hard drive and the ability to generate and edit citations resumed.
  • The OneDrive issue is listed in step 7 of the troubleshooting -- as noted there, it goes away for most people when removing spaces in the filename.
Sign In or Register to comment.