ZoteroBib accessibility

This discussion was created from comments split from: zbib.org feedback.
  • Can you also check your accessibility of the site. This is a great option for students with visual impairments when the Zotero app is just a little overwhelming. I was testing this and trying to write a script for a student using JAWS and I am not able to select a citation style. It does not act like the copy button with the ability to navigate to the dropdown arrow and expand it with JAWS and then make a selection.
  • From what I can see, once focus is moved onto citation style button, voice reader should say what current citation style is. Pressing space bar or return should open the list which should allow picking citation style. We generally test accessibility with Voice Over. I'll see if we can improve the text reader feedback and general compatibility with JAWS.
  • JAWS says it is undefined and you cannot move to the dropdown arrow, as you can with the copy dropdown. It says it is undefined and does not indicate that it is even a selection dropdown.

    The "Bibliography" heading is actually an input text box. I can type in it. Then when I focus on the citation style drop down it reads the "MLA... edit unavailable."

    When I get to the "Copy to Clipboard" it says unlabelled button, press enter to activate, which when I enter it copies to clipboard. I can then tab to the dropdown, which is also an unlabelled button which I am told to press enter to activate and I am given the dropdown to select.

    Hope this helps. Let me know if I can be of any assistance.
  • (I think zbib accessibility should probably go to a new thread, but for now:) I'm seeing some weird interaction of zbib.org with a screenreader with both Narrator and NVDA and also a number of buttons that aren't labelled properly. The keyboard navigation actually seems fine without screenreader.
  • I tried it first with keyboard navigation and it worked well, which is why I thought it might work with JAWS.
Sign In or Register to comment.