[BUG] can't select new notes to edit

Using b6 on Linux (64-bit xubuntu), a new issue: if I create a new note, I cannot select it to edit it. I can, however, select an already existing note.
  • How are you creating the note?

    Personal library or group library?

    Library or collection?

    Report ID?

    Does this persist after switching collections or restarting Firefox?
  • Sigh. I created the report and copied the number to the clipboard, but thought I'd restart to check your last question (should have done that earlier of course). Unfortunately, that cleared the clipboard as well. So I don't know how to get you the report number.

    That aside, the answer to your last question is "no", so I guess this is less important.

    The answers to your other questions:

    It made no difference how I created it: contextual menu and "add note" from the pane yielded the same result.


    Library (a note attached to a new item).
  • Oh, one other potentially relevant piece of information: normally when you create a note, the TinyMCE interface opens up. In this case, it didn't, and all I saw was an "untitled note" line (no TinyMCE).
  • Also on Linux I see half of this problem, the less problematic half.

    When I create a note by right-clicking on the item in the middle pane, sometimes the note is created but not opened up in TinyMCE. This happens quite often but sporadically and I can't figure out any pattern to it. However I've never had any problem selecting the note item - the new "untitled note" is sitting there and a left click opens it up.
  • I have the same problem here, Zotero version 2.0b7.6 under Fedora, Firefox 3.5.

    I can create notes but no way to edit them. I can delete them, though. I can't edit existing notesneither, and it makes no difference creating the note on the central panel with the contextual menu, or by going to the notes tab and adding a note.

    Report ID: 1281859644

    (The report has many "Sync already running" warnings, but also the error related to editing notes)

    Looking forward for a fix... I use notes a lot and not being able to edit them leaves me almost without a properly Zotero to me.
  • Have you restarted Firefox?
  • Cool, I restarted again, didn't work, waited some minutes and now it works... well, thanks Dan!
  • I've started seeing something similar to what bdarcus described, sporadically but quite regularly. Additionally with existing notes, when I select the note (either in the item list expanded "tree", or from the notes tab), nothing happens. Double-click opens the note in a separate window.

    In all cases restarting zotero fixes the problem, for a while.

    One difference from my previous report, I'm now running 64-bit ubuntu. Doesn't seem like that could be the problem though.
  • This may be more serious than I thought. Some notes I entered yesterday are gone. Some really important notes. Looks like the missing notes aren't on the server or in any of my backups.

    That could be unrelated to the problem in this thread, which seems to be a UI issue. However it coincides with when I started to see the UI problem.

    I'm not sure how to debug this, any suggestions would be welcome.
  • So everybody experiencing this is on Linux?

    alexu: If you think they were ever synced to the server, we can look in the logs. E-mail support@ with specifics if you want.
  • Looks like we're all Linux users. I may have a use case to reproduce what may be the issue, with a brand new library, no other plugins. Unfortunately I can't test this carefully right now but here it is:

    - right click on an item, new note
    - edit the note
    - item "tree" is expanded, showing note
    - right click on the new note, duplicate item
    - something weird happens

    Would be interesting to know if that is reproducible. I'll run through it tonight more thoroughly.

    A few unlikely factors: I have the pref set so double-clicking does NOT open items, but opens and closes the tree view. The notes I was taking included non-western (Japanese) text. I've seen some issues with recent versions of the YASS plugin but had that disabled.

    Dan, thanks for the offer but I'm pretty sure this never synced. On further investigation I lost very little, just one reading I'll have to go back over.
  • OK, for me the operation above seems to consistently cause a problem. This is on ubuntu 9.10 64-bit firefox 3.5.7, running a new profile with no plugins except zotero, and a library with just a couple test items.

    - right click on an item, add note
    - item "tree" is expanded, showing note, cursor is in note editor
    - enter some text in the note
    - right click on the new note, duplicate item
    * note does not appear, some existing sibling notes disappear, note editor is displayed but blank, selecting item does not display "info" pane, you see only the blank editor

    Restart firefox and everything is back to normal. The note that you selected to duplicate has been duplicated.

    In debug output I see this suspicious message:

    zotero(3): Item already exists outside of collection in Zotero.ItemTreeView.toggleOpenRow()

    Can anybody reproduce?
  • edited January 22, 2010
    Those steps don't show the bug here on 32-bit Linux (jaunty on a netbook, FF 3.6). Japanese text in one or more notes doesn't seem to cause a problem.

    I wasn't able to find a pref or changing the effect of a double-click. Where is that one?

    (EDIT: found the pref in about:config and turned it false. Duplicating notes still works normally, no sign of trouble on the atom netbook.)
  • Can anybody reproduce?
    Yes, thanks. Fixed in the latest dev build. I wasn't able to reproduce loss of data, but it's plausible this could have caused enough UI weirdness for typing into a single note to not save correctly.

    The error in question can still occur when dragging child items between different parent items. We'll see if we can clear those up.
  • I am having the same problem as bdarcus initially wrote about but on a windows machine. For instance, just added new note but couldn't open to edit. Tried a few different times, deleted it and created it again. Then stopped to search the forums and now I can open it, a few minutes later.
  • edited March 15, 2010
    SarahKiva: There are currently some UI glitches if a sync is ongoing. If that applies to you, try editing the note by simply expanding the parent item. I can reproduce a glitch editing notes during a sync only by trying to open it from the Notes tab.


    Closing this thread, since much of the above discussion is about an error that was fixed.
This discussion has been closed.