Sync all files not working

I want to download all attachments locally. I tried setting:

Download files: at sync time

in the Sync options (and with Sync attachments files set).

However, syncing is not downloading all my files, as I expected. What should I do?
  • I think the zotfile addon will work for you.
  • No, ZotFile isn't relevant if you're using Zotero Storage or WebDAV syncing

    Generally this
    I tried setting:
    Download files: at sync time
    should work. If it doesn't, first make sure that your files are actually only, checking the web library for one of the files that didn't download. If the file opens in the web library but didn't download, use "Reset File Sync History" under "Reset" in the Sync tab of the Zotero preferences.
  • Yes, I made sure all files are available online (I'm using Zotero to store the library and attachments).

    Before reading your replies, I decided to unlink my local account (removing all local data), and link it again. This successfully triggered a full sync, which appears to be also downloading attachments.

    However it's relatively large library (~20Gb), and it's been syncing all night (over 12 hours) but it hasn't finished. Is there some setting I can toggle to make it go faster? Maybe it has a download / upload bandwidth limit setting somewhere?

  • No. Needless to say, we don't recommend unlinking your library — there's no reason to do that.
Sign In or Register to comment.