Keep getting an error trying to add references

I'm on a Mac with the latest MacOS (Ventura 13.0.1 (22A400)). When I now try to add documents from Chrome with the Zotero Connector I keep getting strange problems. At first nothing happens, then if I try again it will import the first page. Then I go to another page and it start to import, but then gives an error recording the document about 2/3 of the way down the list. It says to consult the converters page (the message is in French on my computer, as I am a French speaker).

I tried removing all the extensions, like Better Bib text and others, then I tried deleting and re-installing Zotero and the Chrome connector, a few times. I tried all the other proposed resolutions online, but still, I keep getting the problem.

Any ideas what I can do ? I really need to get this working as I use it extensively in my research activities and for systematic reviews I'm working on!

Thank you
  • Yes, I did before posting but it did not resolve the issue.
  • You need to follow the whole page.
  • edited November 30, 2022
    [Edited] The page asks for very specific information that we would need to help you further. If you had actually gone through the whole page, you would be providing it.
  • I really don't appreciate being called a liar, but since I'm trying to find a solution to my problem I will politely disregard this and try to answer all the questions I identified from the troubleshooting page.

    Here is one of the URLs that isn't working but I tried several different ones at at least 2 universities where I have accounts :,638

    There is no debug ID

    There error message is: Une erreur s’est produite lors de l’enregistrement de ce document. Consultez Résoudre les problèmes de convertisseur pour davantage de précisions.

    I am accessing this in Chrome with the Zotero Chrome connector.

    I removed all the Zotero add-ons or extensions, reinstalled Zotero (removed, rebooted, reinstalled) and the Chrome extensions

    It used to work in the past but this was a few months ago and I have since upgraded MacOS to the latest version

  • I really don't appreciate being called a liar
    Then don't keep saying you've done something you demonstrably haven't done — it just shows a disregard for the time of anyone who might try to help you here. The last step on the page could not be clearer:
    14. If none of these solutions solve your problem, we'll need additional information to further debug your issue. Please create a new thread in the Zotero Forums — or use your existing thread if you've already created one — and provide the following:

    - The exact URL of a page that isn't working (even if none are)
    - A Debug ID from the Zotero Connector for reloading the page and attempt to save or, if you're only getting a webpage icon, for reloading the page.
    - What it says in the popup when you try to save (e.g., “Saving to My Library” or “Saving to”)
    - The name of the translator from step 10, if applicable
    You didn't provide any of that after I twice said to follow the whole page, and you still haven't provided all of it.
    There is no debug ID
    "Debug ID" is a link to instructions for providing a Debug ID.
  • As best as I can tell, this would be the debug code that would be relevant, as the overall code is quite too big to paste here. This is what I get at the tme the error appears.

    zotero(5)(+0000006): HTTP/1.0 200 OK
    X-Zotero-Version: 6.0.18
    X-Zotero-Connector-API-Version: 2
    Content-Type: application/json


    zotero(5)(+0003415): POST /connector/getSelectedCollection HTTP/1.1
    Connection: keep-alive
    Content-Length: 2
    sec-ch-ua: "Google Chrome";v="107", "Chromium";v="107", "Not=A?Brand";v="24"
    Content-Type: application/json
    X-Zotero-Version: 5.0.100
    X-Zotero-Connector-API-Version: 2
    sec-ch-ua-mobile: ?0
    User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
    sec-ch-ua-platform: "macOS"
    Accept: */*
    Origin: chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc
    Sec-Fetch-Site: none
    Sec-Fetch-Mode: cors
    Sec-Fetch-Dest: empty
    Accept-Encoding: gzip, deflate, br
    Accept-Language: fr-FR,fr;q=0.9,en-US;q=0.8,en;q=0.7

    zotero(5)(+0000030): {"libraryID":1,"libraryName":"Ma bibliothèque","libraryEditable":true,"editable":true,"id":187,"name":"IT_Risk_Management","targets":[{"id":"L1","name":"…","level":0},{"id":"C164","name":"…","level":1},{"id":"C186","name":"…","level":1},{"id":"C187","name":"…","level":1,"recent":true},{"id":"C188","name":"…","level":1},{"id":"C173","name":"…","level":1},{"id":"C170","name":"…","level":1},{"id":"L10","name":"…","level":0},{"id":"C163","name":"…","level":1},{"id":"C162","name":"…","level":1},{"id":"C156","name":"…","level":1},{"id":"L9","name":"…","level":0},{"id":"L5","name":"…","level":0},{"id":"C182","name":"…","level":1},{"id":"C31","name":"…","level":1},{"id":"C30","name":"…","level":1},{"id":"C41","name":"…","level":1},{"id":"C29","name":"…","level":1},{"id":"C43","name":"…","level":1},{"id":"C33","name":"…","level":2},{"id":"C32","name":"…","level":2},{"id":"C38","name":"…","level":2},{"id":"C40","name":"…","level":2},{"id":"C42","name":"…","level":3},{"id":"C39","name":"…","level":2},{"id":"C181","name":"…","level":1},{"id":"C45","name":"…","level":1},{"id":"C44","name":"…","level":1},{"id":"L11","name":"…","level":0},{"id":"C160","name":"…","level":1},{"id":"C161","name":"…","level":1},{"id":"C158","name":"…","level":1},{"id":"C159","name":"…","level":1},{"id":"L8","name":"…","level":0},{"id":"C150","name":"…","level":1},{"id":"C176","name":"…","level":1},{"id":"C130","name":"…","level":1},{"id":"C174","name":"…","level":1},{"id":"C178","name":"…","level":1},{"id":"C177","name":"…","level":1},{"id":"L7","name":"…","level":0},{"id":"C124","name":"…","level":1},{"id":"L4","name":"…","level":0},{"id":"C27","name":"…","level":1},{"id":"L3","name":"…","level":0},{"id":"C48","name":"…","level":1},{"id":"C47","name":"…","level":1},{"id":"C46","name":"…","level":1},{"id":"C28","name":"…","level":1},{"id":"C25","name":"…","level":1},{"id":"C49","name":"…","level":1}]}

  • The Debug ID is the number in the popup after you click "submit" -- something like D123456789 (the code you posted doesn't contain any relevant error).

    Also, the name of the translator -- see step 10 of the troubleshooting guide and more precisely what you're doing on the page you linked to above -- i.e. are you just clicking on the Save to Zotero icon (if so, is it a folder or some other icon?) or do you actually get to select items from a list first (if so, which ones do you select)?
  • OK, thanks but I'm not clicking on Submit anywhere. I select the folder icon in Chrome once I'm on the library page, having done my search query. I do click on OK after chosing Select All. I looked for a number similar to what you indicate, but there is none to be found.
  • Step 4 of the linked instructions for the debug ID ( ):

    "Go back to the Advanced tab of the Zotero Connector preferences and click Submit Output."
  • OK, and you're saying this works unreliably? Sometimes you can save all from the first page and it fails on the second page etc.? Or does it always get stuck on the same item on the 2nd page (let's disregard the 'nothing happens' attempt for now). If so, can you isolate which item that is?
  • OK, I finally understood what was described: Le Debug ID est D1970414029
  • It does seem to be unreliable. The first page usually works on the second try and then it fails half-way into the second page and other pages after that as well.
  • It seems to fail often on the same item but not always.
  • Ok, I'll see if I can reproduce that. What's the other library catalog where this happens?
  • I use , which actually links to

    And the other is but is actually linking to

    SO it would appear that both schools are using, perhaps as a cloud solution for the libraries
  • OK, thanks -- I'm able to reproduce this and working on a fix.
  • (3)(+0000001): HTTP GET

    (4)(+0000003): Translate: Binding sandbox to,638

    (4)(+0000006): Translate: Parsing code for RIS (32d59d2d-b65a-4da4-b0a3-bdd3cfb979e7, 2022-07-14 16:45:00)

    (3)(+0000005): Translate: RIS: Dropping line outside of RIS record: <!DOCTYPE html>

    (3)(+0000000): Translate: RIS: Dropping line outside of RIS record: <html lang="fr" data-language="fr">

    (3)(+0000000): Translate: RIS: Dropping line outside of RIS record: <head>

    (3)(+0000000): Translate: RIS: Dropping line outside of RIS record: <meta http-equiv="content-type" content="text/html; charset=utf-8">

    (3)(+0000000): Translate: RIS: Dropping line outside of RIS record: <meta http-equiv="X-UA-Compatible" content="IE=EDGE" />

    (3)(+0000000): Translate: RIS: Dropping line outside of RIS record: <meta name="format-detection" content="telephone=no" />

    (3)(+0000001): Translate: RIS: Dropping line outside of RIS record: <meta name="viewport" content="width=device-width, initial-scale=1" />

    (3)(+0000000): Translate: RIS: Dropping line outside of RIS record: <title>Interface Discovery</title>
    @adamsmith: It's getting an "Interface Discovery" page instead of the RIS file. Is that what you're seeing?
  • Yeah, it's two issues: the webpage version of the RIS is always loaded, but that actually still appears to work. In addition, parsing the databaseList is broken (hence databaseIds=null) and that breaks RIS retrieval for some items.
  • @adamsmith: it works better. I was able to import the results for multiple pages but had the same error after 9 pages (6 on and then 2 on . As well, I noticed that the first import attempt on a library nothing happens and when I try again (a second try) then it works.

    As I'm working with a systematic review protocol, I download multiple results to Zotero from 2 different libraries and from Google Scholar. Google Scholar seems to work fine.
  • Is this for the same search you link to above from Concordia? I'm able to save all 91 results I get there. If not, could you link to the search you're testing with? And if you try the same, 9th page of the search results again, does it fail again?
Sign In or Register to comment.