Zotero destroying all text after bibliography in OpenOffice

The newest version of Zotero has a very nasty bug. It at least affects OpenOffice 3.1.1 for Mac OS X.

I tried to add a multiple source citation. I got an error. The sources added anyway. My bibliography was updated, and EVERYTHING after the bibliography was erased. In this case it was all figures and tables of a manuscript. Furthermore, the OpenOffice file seems to have saved this to disk without my intervention so that I could not even quit the file and reopen it to see it in original condition.

I just updated Zotero this morning and AFAIK am using the most current version (with FireFox 3.5).

In the report error dialog, it gave the following reference number: 1541727333

  • do you remember the error you got when inserting the multiple citation?

    This all sounds a bit strange - e.g. I can't really see Ooo saving something without you at least pressing cmd+s so there is a good chance this may be a bug in Ooo (or maybe even just in your Ooo installation) rather than zotero.
  • If you inserted your bibliography before you inserted everything after it, then you probably inserted the following figures into the bibliography section (which is shown in a gray box to differentiate it from the rest of the document). When Zotero updates the bibliography, it rewrites this entire section. We should probably insert a carriage return after the bibliography section in order to make it harder for this to happen (although the easy workaround is to insert some content after the bibliography before inserting the bibliography).

    I cannot, however, explain why OpenOffice.org saved the file without your intervention, unless you specifically configured it to do so.
  • It's possible that I unconsciously pushed cmd-s. However, the destruction of everything after the bibliography seems directly related to Zotero.

    The error was quite long and Java related of course.

    I'll check about entering all figures into the bibliography area. If I did, it is completely invisible.
  • Good ideas but didn't work. There is no indication at all that my figures were within the Zotero bibliography area. Nevertheless, I copied all the figures to a location in front of the bibliography, did a refresh and they survived.

    Next I deleted my bibliography and reinserted it before the figures. Note that my figures were already there when I inserted the bibliography. I did refresh, got the same error and all figures, text, and table after the bibliography disappeared. I did a screenshot of the error (might want to make these copiable in future versions) and posted it at...

  • edited January 4, 2010
    I have the same problem. Updating the bibliography once puts the first line of the text after the bibliography on the same line as the last bib entry (that is, it becomes part of the bibliography entry). Updating again after that removes all content after the bibliography (several paragraphs, tables et.c.).

    Openoffice 3.1.1, Zotero 2.0b7.6, Zotero OpenOffice Integration 3.0a5, Firefox 3.5.6, Ubuntu linux 9.10
  • edited February 2, 2010
    I just ran into a similar problem when adding an appendix (including some more references) behind the bibliography in a MS Word 2003 document. Refreshing while the document was open didn't change anything, but after closing and reopenning it everything following the bibliography had disappeared (no error messages at any point of time).

    Have there been any new developments or ideas concerning the solution to this problem?
  • I don't know about new ideas - but it's perfectly feasible to have an appendix after a bibliography if you are mindful of where it goes in the document - i.e if you have a page and section break after the bibliography you should be fine.
Sign In or Register to comment.