error when opening pdf attachment in group or private library on zotero-website

I run a private Group in my Zotero account that contains several library items with attached pdf file. When I want to read a pdf file, I should be able to log into my account and doubleclick on the item. But if I do so, I run into this error message: "PDF.js version 2.8.159 (build:fdde9578b) Nachricht: Network error when attempting to fetch source".
(btw.: It is annoying that it is not possible to copy&paste that message)

I am using Firefox version 107.0 on Linux (Ubuntu 18.04.6lts) and Zotero 6.0.18

In the synched Zotero desktop application, I can open the pdf file without problems (also if the pdf was not attached by me but another group member).

If I click on the Website Zotero page on the item only once I get the information about the item in the right hand sidebar/pane. If I choose the tab "attachment" and select the attached pdf I got two buttons "open" and "Download". With "open" I get the same errormessage as above mentioned. Clicking on "Download" I get the error message: "Error. Unable to communicate with Zotero server. Please check your connection." Again: My internet connection is fine and I am logged in at zotero.

Finally: when I use the selection-arrow next to "Download" and choose "Download (no annotations)" the pdf opens in a new window of my browser.

Thus, it seems the problem has to do with annotations, but the pdf has no annotations and I tested this with various pdf files.

I also tested it with a pdf attachment in my private library with the same result.

My best regards
  • Uptdate:
    using ungoogled Chromium Browser (Version 107.0.5304.110 (Official Build, ungoogled-chromium) (64-Bit)) the pdf functionallity seems to work fine.

    Anyway my Firefox is recently updated and I think Zotero should not force its users to use a specific browser
  • It's not a Firefox issue -- Firefox in general works fine with Zotero web PDF viewer.
    Try with all Firefox add-ons disabled for tagging -- I'd be particularly interested in any privacy-related add-ons, which might interfere with Zotero loading the PDF viewer app.
  • @adamsmith Thanks, that did the trick.
    Noscript and uMatrix did allow, but did block x-site-loading from the Domain.

    Unfortunately, neither in Noscript nor in uMatrix a option did not appear on calling the page before I temporarily allowed all sites for that browser tab. It seems that the zotero site tries to load from after the page itself was already loaded, because also in my intents before mentioned I could see the panel of the pdf-reader but the pdf itself did not load into the reader.

    A more informative error message that points to the x-site-loading from to would be helpful.
  • Still I wounder why the download option also did not work while download without annotations did work.
  • I haven't checked the code, but I assume the export function calls the same pdf library that displays the items in browser to write the annotations to the file before download, and Zotero probably decided it was better design to always go that way rather than check for the presence of annotations for that particular item first and have two different download routines with the same button.
Sign In or Register to comment.