Issue Typing Zotero Notes—Sluggish Delayed Appearance of Letters

Hello : I have an issue typing notes in Zotero. When I type, the letters are delayed for a few seconds. Once I start typing, this issue progressively gets worse (longer delays before letters appear). I've also noticed that at times if it occurs for a long duration it can lead to the menus being unresponsive.

I have tried eliminating all addons. I also reinstalled 2x, each time to a new location—always trying without addons. I use the beta version.

When I am not typing, Zotero behaves normally. No "slow" issues dragging annotations to a note, etc.

I thought it was Grammarly, but I have exited it entirely. Grammarly also has an exception set so that it is not active with Zotero. But, it reminds me a little of Grammarly behavior when it is on for OneNote—it gets sluggish and hitches.
  • This certainly sounds like a conflict with something else installed on your system. We haven't had any other reports of this.

    If you provide a Debug ID for typing we can see if anything shows up, but I doubt it.

    You can also try in an empty Zotero library in a different OS user account. If it doesn't happen there, that would be one indication that it's something installed in this account (though there could be something system-wide that's interfering).
  • Hi dstillman. I think it's something like you describe as well. I will try the different OS account. Here is the Debug ID information from the clipboard: D698747331

    Thank you for your insights and help
  • Hello again dstillman. I tried a different user and the problem was system wide. Despite uninstalling McAfee long ago, there were 5 processes that were unstoppable and loaded despite disabling them from loading on boot. I deleted them in Safe Mode and to my surprise, it resolved this issue. Thought I'd share this in case someone else encounters it. Thank you for your time.
Sign In or Register to comment.