Scopus translator needs an update

It seems that Scopus is working on a new search engine. At the moment, it's only available as a beta preview.

The big problem is that somehow they broke also the old one: when in the page with the search results, zotero connector still sees all the references, but gives an error when trying to import one.
The import of a single record still works though (i.e.: opening an item and using the connector from there).

Maybe if it's an easy fix you could check it? since we don't know when the new versione will go live. when it'll go, the translator definitely needs work.

To check:
Try any search and importing from the results list.
  • Works for me -- Scopus is very aggressive in locking out bot-like behavior, so if you're trying to scrape 10-20 items quickly, that might be what you're seeing.
  • How did you make it work exactly?

    My test was:
    - type any research
    - on the result page, click on the connector icon (the yellow folder one)
    - select just the first result
    "An error occurred while saving this item. See Troubleshooting Translator Issues for more information."

    Every time I tried I've got the same error so far.
    If I open the first result (the page with the title, abstract, reference...), the connector works, but never from the results page
  • go to the scopus homepage
    search for testing (I tried in both all and title/abstract/keywords mode)
    import the first two results. Which browser? Could you create an debug ID for a failed import from the browser connector?
  • Done, still experiencing the same error, the ID is: D1749553250
  • Sorry, this was just a bug in the latest Firefox connector. Should be fixed now in 5.0.102.
  • I've just tried it with firefox connector 5.0.102 and it works as intended, good job! thank you.

    For future reference, the new interface still needs work
  • For future reference, the new interface still needs work
    Not sure what you mean by that.
  • I mean that Scopus is giving their users a preview of a new search interface, which is currently in beta: when you do a search, you'll see a banner giving the chance to try it.
    If you switch to the new one, the connector won't see the reference and gives only the option to save the web page, so my guess was that the translator needs an update to work with that, but I could be wrong
  • @ezellohar -- the new search should now work in addition to the old one.
  • edited November 10, 2022
    I've tried but it still gives me the option to save the web page, not the folder with references. (Using Firefox/waterfox)

  • Can you try updating your translators first in Zotero (Advanced tab of the preferences) then in the Firefox Zotero Connector (also advanced tab). I tested this yesterday & it worked fine with the update.
  • I already did it before sending the log output. I've also tried using Zotero 6.018 beta, but I still get the same behaviour
  • For me, the translator doesn't reliably detect when you just switch over from the old interface, but if you either reload the search from the new interface or use it for search, that works fine.
    If that's indeed the issue, I dont' think it's worth spending much time on since it's transitional until they move to the new interface.
  • You're right, after several attempts, I can confirm, the trick is making completely new searches with the new interface.
    For me, simply reloading the results page, didn't wake up the connector.

    A part from the sudden switch between versions, the connector is fully functional then, so you're right that it doesn't need any more work. Let's hope they don't change everything in final version to break things (wouldn't be the first time, right?)

    Thank you for the support, that was FAST.
  • It seems that Scopus finally updated its search engine to the new version, making it default. At the moment, the translator is not longer working in the search result screen (it tries to save the web page, not the folder where you can choose the elements to import).
    The single document save option still work as intended.
  • Sorry for the delay here -- this should be start working again now
  • That's awesome news, but it still doesn't work here, here's my output: D1180386232
  • Tried again today and it's working. I'm posting to let anyone else interested know.
Sign In or Register to comment.