Royal Society Philosophical Transactions B

I've just created a citation style for the Philosophical Transactions B for the Royal Society (UK). I'm happy to upload it, but it seems like either 1) my password is not getting recognized or 2) the location of the svn style repository has changed. I could use some advice in re-establishing my access to the svn (I did have an account and uploaded a style a year back).

I've run the style through the validator as well as checked in other ways and it looks good. Still, someone besides me might like to test this style. Since I can't attach it here, I'm happy to send it to anyone if you email me at

  • You can fill out the access form again and we'll reset your password.
  • michael - I suggest uploading styles for testing rather than posting your e-mail address as an invitation for spammers ;-).
    I've been very happy at but I'm sure there are many other sites that will do the job.
  • Thanks Dan. I've filled out the form to match my existing Zotero forums id and pw.

    Adam, I don't know about I can post to my website at ASU.

    You can download the Royal Society style at:
  • is pretty neat. To test it, I posted the style at:

  • I like it because I can make small changes right there and because people can have a quick look at my code.
    If you want people to download the actual csl, they should use the "Raw" link (top right)
  • 2) the location of the svn style repository has changed.
    The current location of the styles in the SVN repository can be found at the bottom of the styles page (
  • Any feeling for how long I should wait before posting this citation style?
  • go ahead and post it - it's not like you can't change it once it's up.
  • I accessed your svn previously and even committed a style. I reregistered a few days ago to make sure my ID and password were correct. However, whenever I try to access the svn, even to do a checkout I get a PROPFIND error.


    svn: PROPFIND request failed on '/svn/csl'
    svn: PROPFIND of '/svn/csl': 501 Not Implemented (

    I have a Mac with a reasonably current version of SVN -- that I use regularly to commit to an open source project for which I'm on the dev team. I'm using the same SVN clients that I've used for the past several years.

    Any suggestions?
  • Another version of the error I get

    PROPFIND request failed on '/svn/csl'
    PROPFIND of '/svn/csl': Server certificate verification failed: issuer is not trusted (
  • In the first one, you're connecting via HTTP rather than HTTPS.

    In the second, your SVN client appears to not have up-to-date certificates or some similar problem. The cert is valid.
  • I've tried both https and http and get the same result.

    I have subversion 1.4.6. Is this a problem? I used it before with the zotero svn with no problem and currently use it on a regular basis for other svn sites with no problem.

    I will probably upgrade to 1.6.6 soon, but it would be good to know if there is something else needed.
  • Couldn't really tell you. Nobody else has reported issues.

    You could try purging the cached files in the ~/.subversion/svn.ssl.server/ directory.
  • I've tried both https and http and get the same result.
    Also, it's not the same result. The first one is a different error message, and it simply indicates that Subversion isn't supported by the server, which is what anyone would get for HTTP.
  • I upgraded to subversion 1.6.6. Now I get the following error when I try to do a checkout:

    OPTIONS of '': Server certificate verification failed: issuer is not trusted (
  • ./subversion only has the following directories.

    README.txt auth config servers

    Note that I am using this on a Mac OS X 10.5.6
  • I've committed on other svn sites since this has come up. No problem with my old version or with the newly installed 1.6.6. I accessed the zotero svn previously with the same computer I'm using now.

    I've tried to access the zotero svn with my ID/pw and anonymously. I've tried several different clients. All attempts give me the same kinds of errors about certificate verification failure.

    Anyone have a suggestion as to what is wrong? Is there an svn manager at GMU I should contact?

  • Here is something interesting I think...

    cmb-MBP-2:zotero_styles cmbarton$ svn unlock --trust-server-cert --non-interactive
    svn: Repository moved permanently to ''; please relocate
  • Finally got it. Some change in the server required a new certificate. Considerable futzing and trial and error finally got it worked out.
Sign In or Register to comment.