Sync Issue: File in Web Library does not show up in ios apps

Hi everyone!
I have the following issue: I attached a pdf file to my library in Zotero on my laptop, with a complete parent item. Both the parent item and file have synchronized with the web library (as I can see the parent item and also open the pdf there). But this entry and file did not synchronize with either of my ios devices (both phone and ipad).
Other items, be they standalone notes, parent items, etc. continue to synchronize, also newer ones.
What kind of information from me would help you to find out what the issue is on my side? Any help would be greatly appreciated!
  • Can you provide a Debug ID for trying to open the PDF in the iOS app?
  • Thank you!

    I might be wrong, but don’t think that this works in this case here because the files simply are not there—neither the parent file nor the pdf show up. When I search for the file on the iOS app, it is as if it didn’t exist. With no entry for me to click on, there is no process which the Debug ID might pick up on, if I understand it correctly.

    It seems to be a sync issue, but when I attempt to sync, the iOS app doesn’t show any errors either. And there are both newer and older files which have synced without any problems.

    At yet, the file and parent item are visible when I open my Zotero Library in the browser, just not on my two iOS devices.

    Any further tips for how this might be solced would be greatly appreciated!
  • Sorry, I missed that you said the parent item didn't sync either.

    If you make a change to the parent item online (e.g., changing any field), does the item sync down to the iOS app?

    If not, can you provide a Debug ID from iOS for the first sync after you modify the item online? (It should auto-sync, and you can also force a sync by pulling down on the items list. Just make sure you start debug logging before you make the change online.)

    Also, what is the random 8-character string (e.g., BA4P2VD2) in the URL after clicking the parent item in the web library?
  • Hi dstillman - no worries. I appreciate the help!

    I have several items which did not sync, so I was able to try these four ideas separately:
    - after changing any field in the parent item on my laptop, sync with iOS worked,
    - after changing any field in the parent item online, sync with iOS worked,
    - with a third item, I began with Debug logging on iOS and only then changed a field in the item online (with the 8-character string RK9EXEFZ). Here is the Debug ID from my iOS app: D120758207.
    - and here are two 8-character strings of item which have not yet synced (and I will not touch them for now, so that they will stay this way): 8VCLBBQC, LVL9BZNX

    I hope this information helps with figuring this out!
  • Everything should sync automatically, and if it didn't that would point to a bug, but we can't debug a change made previously. If a change isn't being synced, we'd need to see a Debug ID for it. Otherwise the best we can tell you is to make a change to the item to force the sync.
  • Right, the Debug ID D120758207 is from debug logging that was started before I changed the item. I started logging on iOS, then changed the item online, then synced my iOS app, then stopped logging.
    If you want me to try something else, I have two more items which have not yet synced.
  • Right, but are you saying the item didn’t sync after you changed it? You didn’t actually say that.
  • edited October 13, 2022
    Sorry if I was not clear. The item did sync after I changed it. (And there are still at least two unchanged items which do not sync. I guess if I changed them, they would sync.)
  • Yes, so that’s what I meant above. We’re not able to debug changes not syncing previously.
  • Now I get it, thank you! So if I notice this error happening again in the future, I will see whether I can recreate it while logging a debug. Thank you for your help!
  • Old thread, but I had same issue now. Logging out and in again on the IOS device seems to have solved the problem - at least for now.
Sign In or Register to comment.