Sync Two Laptops


New to Zotero.

Installed it on a Lenovo laptop (running Manjaro Linux) I keep at work and a MacBookPro at home.

Installed the Firefox browser extension on both.

I created Zotero account and logged in on my Lenovo.

On Lenovo, I saved a webpage to Zotero. I can see it listed in my Zotero 'My Library' list.

At home, I opened up Zotero and then logged in to Zotero.

I did not see the page I saved in 'My LIbrary'. So, I clicked on the sync arrow. Still no page listed.

I checked the preferences and seems to be setup OK.

On Lenovo, the data directory location is shown as: /home/marks/Zotero

On MacBookPro, data location is shown as: /users/marks/Zotero

Any suggestions as to how to get syncing working?

Thanks for any and all input!

  • Thanks, but I already reviewed that page.

    Was hoping someone could review the info I posted and spot if I made a mistake with setup.

  • The page ends with a request for specific information that you didn't provide.
  • Thanks, since it didn't sync, I didn't see an error message and thus didn't think there would be a debug ID.

    At office now, but in a few hours when I get home, I can check my MBP to see if there is a debug ID.
  • edited October 5, 2022
    No, a Debug ID is something you generate to share a debug log for a specific operation. The page explains exactly what we need here to help you.
  • edited October 6, 2022
    Thanks, at home now. tried to sync to see if file I created on laptop at work would appear on MBP at home.
    File does not show up after trying to sync.
    Here's part of error log info. Lots of issues listed.

    version => 6.0.15, platform => MacIntel, oscpu => Intel Mac OS X 10.15, locale => en-US, appName => Zotero, appVersion => 6.0.15, extensions => Zotero LibreOffice Integration (6.0.2.SA.6.0.15, extension), Zotero Word for Mac Integration (6.0.3.SA.6.0.15, extension)

    [debug output removed — D.S.]
  • edited October 6, 2022
    (Note that a Debug ID is just that — an ID. You shouldn't post the full log here. And there are no "issues" listed here — this is just debug output)

    If a change isn't being synced, we need to see a Debug ID showing you 1) making the change and 2) syncing, as described on the Changes Not Syncing page. That's the only way we can debug it. Everything should certainly sync, and if it didn't that would point to something going wrong with your initial sync, but we can't debug a change made previously.

    If you're finding that a previously changed item isn't synced now, you can make a temporary change to it — e.g., dragging it to a temporary tag or collection — on either the other computer or in the web library to trigger a sync.

    But if you just use Zotero normally, you should find that it syncs changes as you make them.
  • Thanks again for your input.

    Maybe I'm misunderstanding how this works....

    As mentioned I created a file from a webpage on my laptop at work.

    I thought with sync function that file would show up by syncing my laptop at home. This is what is not happening.

    I do not see the file created on laptop at work after syncing. Therefore, there is nothing to change, since it doesn't exist yet on my laptop at home.

    I was hoping I would see that file at home and then make changes, then through syncing I could see the edited version on laptop at work the next day.

    Am I expecting something that is not part of the syncing function?

  • As I said, everything is of course supposed to just sync. It sounds like for some reason the initial sync didn't work properly for you, but I'm explaining that we can only debug something if you can provide a Debug ID for making a change that doesn't sync, not for something that went wrong previously. I explained how to force it to sync that first item.

    But again, if you just use Zotero you should find that it syncs your data going forward. If you can reproduce a problem, provide a Debug ID for it.
  • Thanks again for your help and input.

    Hopefully, I can get this sorted out somehow.
  • Well, good news....

    Came home today and opened Zotero and Voila! it synced and now I see the 3 files I saved on my other laptop at work.

    Go figure.....

Sign In or Register to comment.