Lookup failed despite identifier present in Worldcat

I'm trying to import ISBN 9780262047036 (which is present in WorldCat, see https://www.worldcat.org/search?q=9780262047036) but Zotero Lookup doesn't find it.

Bug or am I doing something wrong? (I just type the ISBN into the "Add items by identifier field) and hit Enter.)

My logs are at D2004035315.
  • The issue seems to be with a translator. Importing with the browser connector from the book's worldcat page doesn't work either.
  • You're getting an HTTP 403 Forbidden error from WorldCat, but it works for me. Is it still failing for you?
  • Oh, actually, data should come from Library of Congress here, but that request is failing for you — could've been server problems on their end while you were trying, or could be something on your network blocking HTTP (not HTTPS, unfortunately) requests. Is this still failing?

    We'll look into the WorldCat fallback, though. They just made a change the other day that broke that, and we fixed it, but it appears to be broken again now with a different error.
  • When I checked the library of congress via their website, they didn't seem to have the book in their catalogue yet (it came out less than a month ago), but my understanding was that WorldCat will also be checked by default and since I got a hit there, I figured Zotero should find it.

    I tried again now (in Zotero) and it imports without problem, but the record is coming from Library of Congress, so I can't say whether the fallback to WorldCat works or not.
  • WorldCat lookup should be fixed now.
Sign In or Register to comment.