Mac/Word can not edit existing citations

edited September 28, 2022
My issue is about editing, inserting within/deleting existing citations. In Windows it works as intended. But on a latest Macbook air M2, the current office 365 and just installed Zotero, the existing citations are not "seen". Click on Add/edit citation, no listing of the existing citations are shown, it will create a new {citation} instead. I tried this on a new document I created, add citations here and there, and then go back edit. Placing cursor after, between existing citation did not make a difference. All citation fields are in grey permanently. The same works in Word on Windows just fine.
  • edited September 28, 2022
    You're saying you're insert an existing citation, and it's putting "{Citation}" in the middle of the existing field rather than showing the existing citation's bubble in the citation dialog?

    Generally this would just be because something happened to the file to cause it to be flattened. See Existing Citations Not Detected. When you say "go back", do you mean right away, or after saving the file and returning to Word later?

    If you don't think it's that, can you provide a Debug ID for reproducing this, after restarting Zotero and Word?
  • Well, I think restarting Zotero fixed my problem, whether I close/save the document or not. I was creating a new document for testing and insert without closing. I also tried open a previous document with Zotero citations created in Windows. It all seems to work now once I restart Zotero when there is trouble.
Sign In or Register to comment.