"An error occurred during installation" (Monterey 12.4)

Zotero is not installing correctly on my machine. Every time I try installing it into my applications (both user and Macintosh drive) I still get the same error pop up of "An error occurred during installation". Tried clearing cache, nothing. Tried dragging into just the desktop, nothing.

If someone can help me out I'd greatly appreciate it.
  • I'm not really sure what you mean by this. There's no "installation" on macOS — it's just an app in a disk image, and you drag it to Applications, the same as most Mac apps. Can you take a screenshot that shows what you're describing, upload it somewhere (e.g., Dropbox or Google Drive), and provide a link here?
  • Can you take some screenshots of everything you’re doing before you get that?
  • edited June 28, 2022
    @benjuniper: I think what you actually mean is that you're getting that error when trying to open Zotero, not when trying to install it. You install Zotero just by dragging it from the disk image to Applications, and that wouldn't show that error.

    It looks like that's an error from macOS if Rosetta 2 — which allows apps that haven't yet been rebuilt for Apple Silicon to run on Apple Silicon Macs — can't be installed. Generally macOS prompts you before it tries to install Rosetta, so it should be clear that this is happening.

    This error might happen if you're not connected to the internet when you try to open the app the first time, when macOS needs to install Rosetta. If you are online, it's some other problem on your Mac that's causing Rosetta not to be installed, and you'd have to ask Apple or look in other forums for help.

    In case it helps, an alternative method for installing Rosetta from Terminal is here:

Sign In or Register to comment.