Bookmarklet not working on mobile iPhone Safari or Firefox (iOS 12.0)

I used to be able to save snapshots and references to pages from safari on my iPhone using the bookmarklet. Occasionally it would ask me to log in to Zotero first. Now it asks me to log in, but when I press login, nothing happens. I'm sure the password and login details are correct.

I was looking for a way to get the bookmarklet working on iPhone Chrome or Firefox, but the instructions (e.g. for mobile Firefox) on the Zotero webpage don't work. When I long-tap "Save to Zotero", I don't get the option to "Save Link as Bookmark" as the instructions suggest.

Does anyone know how to fix this issue with Safari or how to get the bookmarklet working with another browser?
  • There's currently an issue with Safari 12 and the bookmarklet login page that we are investigating. To make it work, go to in Safari and log in into your account manually before using the bookmarklet.
  • That worked - thanks so much for your help!
  • Has this been fixed? I’m still having the issue and manual login not helping. Using on iPad, now iOS 12.2 (but issue also there in 12.1.x).
  • Same here... After being able to add a paper without any issues through the bookmarklet in Safari (iPad running iOS 12.2) I am suddenly asked to login again... the login window then goes to the Zotero homepage instead of closing and finishing the adding process... Same thing running the bookmarklet on my Mac yesterday!
  • Still not working for me and it’s driving me mad. Would like to know if there’s any work being done on the issue?
  • edited May 13, 2019
    Even if I log into Zotero library first in Safari on the latest iOS, when I try to save an article it's still asking me to log in again, and then switches to the home page. Now it is completely impossible to save references in Safari on iOS. Chrome works fine though.
  • Are you in private mode? The bookmarklet is working fine for me. Does this happen with any site (e.g., this page)?
  • edited May 13, 2019
  • That page works for me. Unfortunately this is likely caused by Safari's Intelligent Tracking Protection, which blocks third-party content embedded on other sites from accessing its own cookies. One requirement for allowing such access is that the third-party site has had first-party access, meaning you've browsed directly yourself. That's determined by machine learning on a per-device basis and is based on, among other things, the frequency of access, which probably explains why this works for us and doesn't always work for others. So it's possible that if you browse around the Zotero site a bit on your device it might decide to start allowing the bookmarklet to work for you.

    We're going to see what we can do about this. In the meantime, you can also save to your online library from the save page, though that won't save PDFs or work with gated sites like the bookmarklet.
  • I’ll try the idea of browsing around on zotero web, but it’s really frustrating because I use my iPad a lot, on the move, to grab materials; and taking time to keep “browsing” is not efficient :( an iOS app would I hope solve this issue?
  • Spencedj: I had exactly the same problem, but disabling the „Cross-Sitetracking“ in the Safari Options helped. Now using the bookmarklet works like a charm.
  • In case it helps anyone; we disabled cross-site tracking, still no go, gave up and entered probably 10 docs manually using Then noticed the bookmarklet started working. So yeh, liking the theory that some AI decided this was a safe operation.
  • Had this problem too - frustrating when travelling light with an iPad. But work around is to download the Firefox browser and use its bookmarklet for saving. Problem is with Safari not Zotero.
  • Rowo: I'm still finding it's hit and miss :-( Safari & iPad is so necessary for my workflow. Hoping for iOS app...
  • - at AndrewFitzGibbon: how use Firefox on ios when can't edit its bookmarks?
  • ok - on ios firefox - have tried using the firefox/android save to bookmark button to add the javascript bookmarklet - it seems to be there - but am getting "an error occurred trying to save..."

    others getting similar? does it self-correct after attempting to add more papers?
  • Does it give an error on all websites? Try a journal article abstract page on a publisher website.
  • I am getting similar messages with both Safari and Firefox on iOS 12.4.1. With some sources I am getting a "Attempting to save using Save as Webpage instead" which does work, but of course the metadata is poor. Two years ago the bookmarklet / Papership combo worked well for Zotero on iPad, but this is now a area of development.
  • This also seems to happen in MS Edge when 3rd party cookies are blocked. Unfortunately, IT policy does not allow disabling this function. Is there any other solution that doesn't require "third party" cookies?
  • I had the issue on Android using Firefox.

    The issue involved the bookmarklet attempting to login with a successful "Authorziation approved" message, before failing to save the relevant page. This issue had seemingly occurred after a new Zotero update had released, or after I had updated my Zotero Connector on PC.

    I changed my 'privacy settings > cookies' to 'Enabled' from 'Enabled excluding tracking cookies' and the issue was resolved. Before that, I would save pages or addresses into OneNote and manually save them to Zotero when back to my PC.
  • Thank you very much - disabling cross-site tracking for Safari worked for me :)
  • I was trying adding pubmed references to Zotero using Safari bookmarklet on iPad (12.9). Although I could use the bookmarklet successfully to add Zotero pages, but not NYtimes, pubmed, etc. Finally worked for all these after switching off Cross-Site Tracking! Annoying, but the only short-term fix until an app or some other fix is out.
  • I turned off cross-site tracking and that seemed to make it work.
Sign In or Register to comment.