items not saved properly from Amazon after the recent update

I updated Zotero this morning, and I'm facing problems in saving items from amazon to Zotero. The item is saved with the webpage title, not with the proper metadata.
Acts of Authority/Acts of Resistance: Theater and Politics in Colonial and Postcolonial India eBook: Nandi Bhatia:
It also shows the following error message even while saving:
An error occurred while saving this item. Try again, and if the issue persists see Getting Help for more information.

Please help, its rather difficult for me to manage without Zotero even for a day!
  • Hi,
    I tried with known translator issues too, but I couldn't identify the problem. But it works fine with Jstor and other catalogue sites. Amazon search results selection console is not appearing, specific product pages are also saved wrongly. I'm a screen-reader user, have submitted the debug report using keyboard. I don't know if it has the info.
    The Id however is:
    site URL:

    Error message is simply this: saiva siddhanta
    An error occurred while saving this item. Try again, and if the issue persists see Getting Help for more information.
    Its saving to the library, not to
  • I'm not sure about the search result pages, but it looks like the "s=gateway" in the individual page URLs is somehow preventing Zotero's Amazon translator from working. I've created a ticket for us to fix that. In the meantime, you can save by going to an individual page and removing the s=gateway from the URL. (I'm not sure what that parameter does or under what circumstances Amazon adds it.)
  • edited April 29, 2019
    From a recent experience I think this _might_ be related to the Smile program that awards a (tiny) percentage of a purchase to a not-for profit of the customer’s choice. I am a Smile participant. Recently I visited Amazon to capture metadata on a book. The site recognized my ip address [or maybe a cookie] and a pop-up asked I wanted to make my purchase from the Amazon Smile site instead. I clicked no and found that I was not able to capture the book metadata. Later that day I made a decision to buy the book. I visited the site and bought the book. Before I made the purchase I was able to download the metadata. Maybe a coincidence or maybe something different about the Smile vs rejected-Smile site. I haven’t tested this but maybe, if a computer is a recognized Smile participant who rejects the offer to connect through the Smile subdomain, the Zotero connector and Amazon translator cannot capture the metadata.
  • I am having the same problem and tried eliminating the s=gateway. It seemed to work, but I kept getting the "Saving" popup and it never saved. Went to a library website and it worked fine.
  • I have the same problem still now. Has anyone managed to understand what is it due to? Thank you for your reply.
  • @claudia.faraone -- the issue as reported here has since been fixed, so we'd need want you to run through the whole troubleshooting list:
Sign In or Register to comment.