Google Scholar saving from search but not My Library

edited January 11, 2018
I can use the Zotero folder icon to save items from a Google Scholar search, but not items from within Google Scholar's My Library. When I try I get the message: "An error occurred while saving this item. Check Known Translator Issues for more information."

I've worked through that list to no avail. My standalone client is on version 5.0.33, my browser extension is version 5.0.31, and I've reset translators. In one thread I read a user in China had a similar issue, apparently due to being on IPv4 (I've tested my connection, and IPv4 is all I have too). See:

Clicking the Import into BibTeX link below a citation does give the @article{etc. info from the Google Scholar Library as well as from search results.

Hovering over the browser extension icon says "Saving to Zotero (Google Scholar)" and the popup says "Saving to [the folder currently open in my Zotero client]". I get the exact same issue in both Chrome and Firefox.

URL where the problem is occurring:,5
The Debug ID is D524245165

I'd appreciate any help! :)
  • I can reproduce this. We'll take a look but not sure how quickly we'll be able to fix.
  • edited January 11, 2018
    No rush, but thank you for looking into it! Your comments in other threads were very helpful. Let me know if you need any other info from me, I'll check back.

    btw, never had this issue in the US, and this is the first time I've tried from overseas (Central Asia). That's why I wondered if my situation may be similar to that user in China.
  • In the mean time, you can select items using the check boxes in My Library and then click the Google Scholar export button to export them as BibTeX and import into Zotero.
Sign In or Register to comment.