Lost most data between Firefox add-on and standalone

I was using the standalone version a while ago, then switched to the Firefox add-on. Initially, that transition seemed to work well, but then I started having sync errors and then received errors that my files cannot be located. I can view the parent items, but not most the PDF's attached to them.
With the new 5.0 version, I hoped this could be corrected, but to no avail. I would appreciate if someone could help me solve this problem.
  • Are you using Zotero on multiple computers? In that case we'd want to have details on the sync errors which are the likely cause of this.
  • Hi, thanks for quick response. I am using it in only one computer. But I am using Zotero storage to sync and upload my files. As of now, it doesn't give any sync errors, but it doesn't let me access to my pdf files either.
    On my web account, I can see that PDF files are registered under parent items, but I am unable to view or download those files when I click on "attachment details".
  • This sounds like you moved your data folder some time in the past when not all files were synced online. See if you can find an old Zotero data directory on your computer. See here for general description of what you're looking for: https://www.zotero.org/support/zotero_data
    the folder would likely be in a hidden path, you'd typically have to specify in searches to include public folders.
  • Thank you again adamsmith. Unfortunately, I am unable to locate that old folder. When you said they would be in hidden path and I need to specify in searches, could you be more specific? I tried to locate the folder by searching a PDF file I know I used to have. It appears in parent items on Zotero. I search for that PDF file by name on Mac, but am unable to locate it in my hard drive.
    Thank you.
  • You can google instructions to search for hidden (and system) files on a Mac -- details differ by exact OS version, so probably easier for you to google it.
  • Hi, I am able to locate the Zotero folder in my computer, but the problem persists. Within that folder, I find another called "storage" and it has several of the PDF files. However, when I search within that folder for the particular files (those I can see in my Zotero library), I am unable to locate them. I would very much appreciate if you could help me resolve that problem. I am really about to stop using Zotero because of this.
  • I'm not clear if you were able to find an _old_ Zotero directory?

    I'm also not following this:
    However, when I search within that folder for the particular files (those I can see in my Zotero library), I am unable to locate them.
    there appear to be some missing words here that play a rather crucial role.
  • Let me clarify. 1) I am able to find a number of folders called "Zotero". One of these folders is the one currently used by the application (Directory: Users/myusername/Zotero). The other folder is called Zotero-Old. This folder has the same directory and appears to be last modified in December 7th, 2017.
    Finally, there is another Zotero folder I found hidden. Directory: Users/myusername/~library/application support/Zotero. Are these the folders you suggested me to find? Or is there another _old_Zotero directory?

    2) The first two folders (Zotero and Zotero-Old) each have subfolders called "Storage". And these have several documents in them. Among these documents within the "storage" folder, I am unable to locate several of the files I am able to view within the Zotero application. To give an example, in my Zotero standalone, I see a parent item X that has a PDF file Y attached to it. When I try to open that PDF file Y, program gives me error that the file must have been removed. When I search for that file Y, using Finder within "storage" folders, I am unable to find anything. This essentially is my problem. I have lost all those files and unable to locate them anywhere.

    3) In the third Zotero folder I found within a hidden path (Users/myusername/~library/application support/Zotero), there is no "storage" folder, but only a "profiles" folder.
  • @dstillman will Zotero ever create "Zotero-old" as a folder? I've never seen this.
  • Sorry I didn't mention that, "zotero-old" was a folder I named when I copied the existing zotero folder to back it up.
  • when did you do that? Before or after upgrading to Zotero 5?
  • It was before
  • OK, so if the PDFs are indeed not in that folder, then updating didn't lose them but they were either never there or got lost previously.

    But you may also just not be finding them in the folder for whatever reason. I'd try this:
    1. go to Zotero-old/storage and select all + copy
    2. go to Zotero/storage and paste
    3. There will likely be a bunch of conflicts -- you want to "Skip" on those

    That will restore all files that were in your pre-Zotero 5 back-up that may have gotten lost during the upgrade.
  • Thank you. I just tried this method, but it seems like both "storage" folders are identical (when I said skip to all, it didn't copy even one file) and had nothing changed. Could there be any other way to trace these lost data?
  • Are there other cases were people lost data while using Firefox extension and standalone together? Any way they recovered it?
  • Generally Zotero doesn't just "lose" data any more than your operating system would randomly delete files, so the answer to "are there other cases" is really no.
    I describe the most likely scenario of what happened above, but I don't see any other places you could look for the files than those three folders. It's also a bit tricky because we have no idea how long this goes back.
  • Well, my question was much more specific then just Zotero losing data out of the blue. When people use standalone and firefox extension together, I wonder, if it had created a problem for other people too. Standalone and firefox extension (at least in the past before the 5 version) were each using different directories to store files. I am trying to understand the source of my lost data, if it was because of the way they (standalone and firefox extension) sync. So maybe it would be possible to locate the lost data.
  • edited January 12, 2018
    The only time Zotero ever deletes attachment files on disk is if you also delete the attachment in Zotero. So if an attachment is missing, either 1) the file was deleted outside of Zotero or 2) the file was created in a different data directory, either on this computer or another one, and not synced to this one. So your only option is to find the data directory where the files were created, either on this computer or another one.
  • edited January 12, 2018
    Regarding the Zotero 4.0 for Firefox to Zotero 5.0 upgrade, see https://www.zotero.org/support/kb/data_missing_after_zotero_5_upgrade for more info. It would've generally done the right thing automatically, or at least warned you about a problem, but that page explains a couple places where you might look if you're not seeing what you expect.
  • Thank you, this was more helpful.
Sign In or Register to comment.