Need to replace «» with “” when pasting a PDF excerpt from Zotero

I'm pretty sure this is quite a newbie one, but I couldn't find any working answer in the forum, hence this post.

Whenever I copy a highlight in the new editor and paste it into my text editor I'm getting French quotes as in the example bellow:

«O ordenamento jurídico brasileiro é o conjunto de» ([Ferraz Junior, 2003, p. 169](zotero://select/library/items/D77GEJPQ)) ([pdf](zotero://open-pdf/library/items/47X3DVBT?page=169&annotation=S5IXYXN6))

However, the default in my native language (pt-BR) is to have start and end double quotes “”.

I've tried editing the CSL file as described in this [post](https://forums.zotero.org/discussion/91512/change-quotation-marks-vs-language-in-the-style-sheet-change-keyword-and-in-author-separation/p1).

However, it did not work.

Can any one please point me out how can I change this?

  • If you go to the Advanced pane of the Zotero preferences, what language is Zotero set to?
  • edited 18 days ago
    Hey dstillman, here's the settings overview:

    1. Advanced pane settings: Português (do Brasil)
    2. Export, pane settings, Item Format: "Associação Brasileira de Normas Técnicas (Português – Brasil)"
    3. Export, note format: "Markdown + Rich Text"
    4. Export, character encoding: "(auto detect)"

    Zotero v. 6.0.13

    In my testing, changing interface language to English made the quotes work as expected (“” in instead of «»). So there may be something wrong with the "Português (do Brasil)" translation setting. I would volunteer to change this if I knew how to do it.
  • edited 14 days ago
    OK, it looks like our translation system automatically applied some of the pt-PT translations to pt-BR. I've fixed all the instances of « and » for the next version of Zotero. Thanks for reporting.
  • Nice! Many thanks for fixing this quickly!

    I’ll wait for the next version and, meanwhile, suggest that people facing the same problems use the English setting instead.
Sign In or Register to comment.