After updating to Monterey Zotero keeps asking for update and quitting

I tried opening Zotero after the update and it keeps giving a Database upgrade error. When it saysCheck for Updates and I do and it gives no updates I click OK and it shuts down.
  • Have you tried reinstalling from the download page?
  • Over and over.
  • Can you provide a Debug ID for Zotero startup, using the "Restart with Logging Enabled…" option?
  • To provide a Debug ID I need to be able to see the Help pulldown icon. Zotero opens and none of those are accessible. It immediately goes to the error message.
  • The error message says that it is a Unix error 13 during operation remove on file
  • From that page:
    (If you're not able to access the Help menu, see Reporting Startup Errors instead.)
  • That did not work because it processes the debug output but the Error message comes as mentioned above and it shuts it down
  • There are instructions on the page to log to a terminal window if you can’t use the debug output window.
  • I did go through the terminal window but the given command results in a debug output but I cannot click submit
  • No, that’s not the instructions I’m talking about.
  • This is what I did
    Open Terminal via Spotlight or from /Applications/Utilities.
    Go to the Terminal menu and open Preferences. In Settings→Window, make sure Scrollback is set to “Limit to available memory”.
    Paste the following into the terminal and hit return.
    /Applications/Zotero.app/Contents/MacOS/zotero -ZoteroDebug
  • I followed those instructions.
    There is no other instruction that I can follow because the others are not relevant since Zotero does not open at all
  • I linked you directly to the relevant section.
    If Zotero is crashing, such that the debug window opened by -ZoteroDebug closes as well, you can log to a terminal window instead. Upload the debug output somewhere and provide a link in your forums thread or email the output to support@zotero.org with a link to your forum thread.
Sign In or Register to comment.