Zotero is not working well with Web of Science recently

When I click the Zotero Connector on Firefox to save journal articles, it pops this:

"An error occurred saving with Web of Science Nextgen. Attempting to save using DOI instead."

Both Zotero and the Zotero Connector extension are updated to the latest version. It worked well when I used Zotero 5. The same problem occurs on all of my computers.
  • Does anyone have the same problem?
  • No, I tested just yesterday (and added support for some additional databases) without any issues. Could you provide a sample URL?
  • edited April 24, 2022
    Your asking of URL helped me find the problem. Thank you!

    When I used the web VPN to access the WOS, Zotero Connector didn't work. But if I use the VPN client, Zotero Connector works perfectly.

    The webpage looks exactly the same in both cases, but the URLs are different.

    I guess the VPN client is a more global and fundamental proxy.

    Is there still a way to make Zotero Connector work on web VPN?

  • By "web VPN", you mean a web-based proxy that you log into on a webpage?

    And are you saying you're still getting the above error, or is something else happening?

    Can you provide a Debug ID from the Zotero Connector for loading a page and failing to save?
  • edited April 25, 2022
    Hello, dstillman:

    The Debug IDs are D710539552 and D994773838. (I followed the instruction provided in the link and tried twice)

    I am still getting the above error if I use web VPN. It says: "An error occurred saving with Web of Science Nextgen. Attempting to save using DOI instead."

    Yes, it is a web-based proxy that allows me to access the school library off campus. To use it, I do not need to install a VPN client and configure anything. I just need to login my account. The URL looks like this:
  • Yeah, that's not a proxy URL format that Zotero understands by default, but you might be able to get it working for HTTPS sites if you create a proxy entry with this scheme in the Proxies pane of the Zotero Connector preferences:

  • Thanks, dstillman.

    I have added "%h-443.webvpn.nwpu.edu.cn/%p" as a proxy scheme in the "Configured Proxies" field. It didn't work.

    It says: An error occurred saving with Web of Science Nextgen. Attempting to save using Save as Webpage instead.
  • edited April 26, 2022
    Can you provide another Debug ID from the Zotero Connector for loading the page and trying to save?

    Make sure you're actually reloading the page while debug output logging is running. Your attempts above just show you clicking on the save button, which will just reopen the popup window if you've already tried to save.
  • edited April 27, 2022
    Hello, dstillman:

    It worked! I have added the proxy scheme and RELOADED the page as you suggested. The connector worked.

    I didn't reload the page after I configured the proxy in the first time.

    Thank you, dstillman!
  • OK, great. That should work for all sites that you connect to via HTTPS — it should automatically detect the proxy as you visit sites and redirect you back through the proxy if you follow an unproxied link for a previously detected site.

    If you connect to an HTTP site via the proxy and find that it's using a different URL scheme, we can help you set that up as well.
  • Thank you, dstillman. Now the connector is working perfectly with me.
Sign In or Register to comment.