OOo plugin 3.0a5 cannot work in Ubuntu 9.10

1) When I try to install the plugin for OOo, I get this message: "Zotero OpenOffice Integration could not complete installation because an error occurred. Please ensure that OpenOffice is closed, then restart Firefox." The extension 3.0a5 is installed in Zotero but not in Open Office. I have installed, reinstalled, and let Firefox detect the OOo paths. To no avail.
2) Since I suspected that this had sth. to do with Java, I uninstalled the Icedtea plugin and tried to install instead the sun-java6-plugin (with the new Ubuntu software center or Add/Remove applications). I got this message: "Package dependencies cannot be resolved. This error could be caused by required additional software packages which are missing or not installable. Futhermore there could be a conflict between software packages which are not allowed to be installed at the same time."
3) I thus went to the synaptic package manager and tried to install the sun-java6-plugin, and get this surprising message: "The following packages have unresolvable dependencies. Make sure that all repositories are added and enabled in the preferences.sun-java6-plugin: Depends: sun-java6-bin (=6-15-1) but 6-16-0ubuntu1.9.04 is to be installed".
What can I do to get Zotero en OOo working together again (in Ubuntuj 9.10)?
Would you please help me to find a way out of this situation?
  • Make sure you have the multiverse option selected in Software Souces, then try

    sudo apt-get install sun-java6-jre
    sudo apt-get install sun-java6-plugin

    I've got it working, so it is possible.
  • edited October 31, 2009
    Hi Jon,
    thanks for your answer. Unfortunately, I cannot get the problem solved. And it is looking more and more complicated.
    1) sun-java-6-bin and sun-java6-jre are installed. The multiverse option is selected in Software Sources. But wheni try to install the sun-java-plugin time and again I get the frustrating message about unresolvable dependencies mentioned above (3).
    2) I went to the Java Tester ( and there I found -as expected- "Browser has Java disabled" (though in the preferences of Firefox Java and Java script are enabled).
    I reinstalled Ubuntu 9.04, but then I got even more problems with other programs, since they seem to have been removed from the servers. Back to 9.10, I got again the error mentioned in my previous message.
    Beside this problem, 9.10 is giving me problems with Thunderbird, etc. all of what did not exist in 9.04, and this is really frustrating. For me, 9.10 has become the Ubuntu Vista. It looks like it is, to my regret, time to upgrade to Windows 7.
    Thanks again.
  • Hmm, not too sure what else to suggest.
    The only thing that may be different, is that I was doing a clean install on a fresh ext4 partition but that shouldn't really matter, worth a go though.
    I'm also running Thunderbird with no problems.
    It might be worth running 9.10 off a usb stick as I first did, just so that you can verify for yourself that it is possible to get openoffice, java & Zotero to all play nicely together?
    Windows 7 seems ... nice ... but I only really use it for gaming.
  • Hi, Jon. Thanks for your quick answer.
    I made first a 9.10 clean install and, as I missed some programs, I then reinstalled 9.04 and used it for a while, but as said, this was not the old 9.04 I had been working with. Then I upgraded to 9.10. Everything looked good, though I missed some programs and the had much difficulty to get some others working well (like the sound settings in Skype). But when I tried to use OOo with Zotero and with Thunderbird, programs I am enterely dependent on for my work and home tasks, the troubles started. OpenOffice in 9.10 does not offer Thunderbird anymore as an alternative Address data source, contrary to 9.04. To get it as such a source would mean to make a lot of tricks in which it is not worth to waste one's time. With the clean install of 9.10, OpenOffice had the horrible Galaxy as only style alternative. Enfin .... open source software not only works now for me better in Windows than in Ubuntu, but, ironically, Ubuntu is even blocking open source software to work well. Maybe when Ubuntu Vista upgrades to Ubuntu 7, I will have to consider to come back to Ubuntu.
    Many thanks, again.
  • OK...
    I just upgraded to 9.10 and everything works out of the box, including the Ooo plugin for Zotero.
    You're last message/rant is probably more intended for the Ubuntu forums, but I'm still a bit puzzled, as Ooo wasn't actually upgraded with 9.10. Skype sound also works fine (if you have Skype 2.1b installed at least, and the 2.0 sound has been a mess all along).

    As Jon says, something seems to be wrong with your repositories. Nothing got removed from 9.04 - that just doesn't happen.

    As for the specific Java problem, I'd try to remove and re-install it in Synaptics.
  • Another 9.10 upgrade here with no apparent zotero problems.
  • Hi, adamsmith,
    apologies for my last message/rant (besides misplaced, my criticism was wrong. I have had time indeed to upgrade to Ubuntu 9.10 in a couple of other PCs and laptops, and the upgrade has worked in each case out of the box, even and best -I think- in an Assus eeepc. U 9.10 is working great).
    I finally could install the sun-java-plugin by installing it with the Synaptic Package manager at the same time as I installed sun-java-6-bin and sun-java6-jre (and not separately after them), and by entering, as Java UNO Runtime Directory, the address file:///usr/lib/openoffice/basis-link/ure-link/share/java/ (i.e. the address of the link to the ridle.jar file, and not the addres of the ridle.jar file itself).
    Many thanks to you, Jon Rubin and alexuw.
  • Hi,
    I had the same problem with an upgatde. Solved by reinstalling:

    sudo apt-get remove --purge sun-java6-bin sun-java6-jre
    sudo apt-get install sun-java6-plugin

  • Hi all,
    I am using Ubuntu 8.04 Hardy and had the same problem although I installed java, zotero and zotero OOo plugin properly. I couldn't find that ridl.jar file asked in Zotero properties. I solved the problem by installing package:
    with synaptic package manager. Then searched for ridl.jar and set its path (which is file:///usr/lib/ure/share/java for me) in zotero openoffice plugin properties.

    hope this helps.
Sign In or Register to comment.