iOS: Can't connect to WebDAV server

edited March 21, 2022
This discussion was created from comments split from: Announcing Zotero 6 and Zotero for iOS.
  • This is a important milestone for me who is doing scientific literature management and reading every day. PDF annotation and notes export function are so usefull.
    In addition, I also installed and used the app, but I found a problem that the app can't connect to synchronization WebDAV server。
  • What platform is this? Can you provide a Debug ID for a verification attempt that fails?
  • @dstillman I installed and used iOS app. To sync attachment file in my Libarary using WebDAV, I click Settings->Account, and I selected WebDav in FILE SYNCING option. when I click "verify server", there is a error tips "Could not connect to WebDAV server". I'm sure my WebDAV server is working properly because I can synchronize files every day。
  • We'd need a Debug ID to say more.
  • The same problem happened to me.
    Here is a Debug ID: D1644195188. Log started when clicking "Verify Server".

    The same configuration is applied to Zotero 6.0 on Windows and Zotero on IOS. It works on Windows but not on IOS.
  • I'm having the same problem. The webdav sync works on my PC, but on the iPad app I got a cannot connect to server message. The debug ID is: D1290784408

    Thank you
  • IP address like “” is working. The domain name like “” is not working. This issue is not happen in windows and macos.
  • @xxx_account: It sounds like you're trying to connect via HTTP rather than HTTPS. iOS only allows HTTP connections to local addresses.
  • @dstillman I use the “” just for an example. Actually my address is “” and I connect to my webdav via http. I also try to connect my webdav service via https with the domain name but it’s still not working. Maybe the DNS services cannot resolve my domain name.
  • @dstillman Apparently the IP address is working and the domain name address is not working in my iPad. I tried to change the DNS services in WI-FI preferences but it still not working.
  • I am experiencing a similar problem: verification of the WebDAV-Server using Zotero for iOS does not terminate (Debug-ID: D2039560692). It does work with Zotero on Windows.
  • (+0015822): HTTP OPTIONS https://webdav.[…]/zotero/ failed with -1
    @eichler: Is there anything unusual about your network connection? Using a proxy? Network firewall? Have you tried restarting your device?
  • @xxx_account: You shouldn't be able to connect to any non-local addresses via HTTP on iOS. If you're having trouble with an HTTPS connection, we'd need a Debug ID.
  • @dstillman: Sorry, mistake on my side: it has been a typo in the user name. But it have been reported in the UI (did only show the processing icon).
  • D58966888 cannot sync file from webdav server using my zotero 6 for ios.
  • edited March 21, 2022
    @luchao91: There's no Verify Server attempt shown there. Can you try again?
  • edited March 23, 2022
    @iami667: That's a server incompatibility that should be fixed for the next version.
  • @ekcheng2: You're just entering the wrong URL.
  • @eichler: Are you still having trouble?
This discussion has been closed.