Integration error in Word 2013

I have been using Zotero for over two years now, and it has been so useful for my works. Today, though, I find myself having quite a troublesome issue, one that I haven't encountered before.

I was working like always with Zotero and Word, then my laptop shuts down due to overheat (caused because I was using it for a prolonged time). I wait 10 minutes till it cools off, and turn it on. I then open Word and Zotero to continue working, but now whenever I try to add a new cite or create a bibliography in Word, a notification pops-up telling me that Word cannot communicate with Zotero (integration error), and that I should check if the Word add-on is enabled. I proceed to go and check, but it says that it is already enabled. I tried disabling it then enabling it again, then updating it, but nothing.

Anyone knows why this problem appeared when I didn't have any issue before? Maybe a file got corrupted when the shutdown happened?
  • Could you submit a Report ID from Zotero?
  • Here is the Report ID: 271116847
  • I was trying to solve this problem again, and now it turns out that the Word plugin was uninstalled? At the time I submitted this post, it was still installed, but now it disappeared. I tried following this guide to re-install it manually (, but to no avail.

    I might need to truly re-install Zotero, but I am afraid of losing my library of articles in the process.
  • Reinstall Zotero from the download page. You're somehow missing the word processor plugins.

    Your data won't be affected, but you should always have a backup of your Zotero data directory — or ideally just your whole computer — regardless. (You can also set up Zotero syncing.)
  • I have reinstalled Zotero, but the plugins still do not appear. I have manually checked the directory that supposedly has the Word plugin (c:\Program Files\Zotero\extensions\\install), and the file is there, but it doesn't get properly installed.

    This has a new Report ID: 595334942
  • Close Zotero, go to your Zotero profile directory, delete extensions.json, and restart Zotero, and see if that helps.
  • edited 8 days ago
    I did that, and the plugins still do not show up. I checked another post that said that I could try to install the plugins by going to Preferences -> Cite -> Text Processors. In said menu, there should be an option that says "Install Word add-in", but it doesn't appear at all.

    In fact, I completely uninstalled Zotero from my PC, and proceeded to reinstall it from zero, and the same problem persists.
  • Create a new Zotero profile (e.g., "Test") and see if the plugins appear in Tools → Add-ons in that profile:
  • That actually worked. The plugins appeared in that profile, and I could start adding cites and bibliographies in Word yet again.

    Does that mean that I will need to always use this new profile now?
  • No, if you close Zotero and delete all the files/folders beginning with 'extensions' in your old profile, I would guess it would work. If not we can try to figure out what other file is the problem here.
  • I did that, and then started Zotero with my "default" profile, and the plugins didn't appear.

    But that suggestion gave me the idea to copy and paste the same file from the "test" folder into my "default" folder (only the "extensions.json" file was on the "test" folder). It seems to have re-installed the plugins, as now I opened Zotero with my "default" profile, and the plugins finally appeared. But the same "integration error" problem I stated at the start of this post persists. At least it is one less problem.
  • Can you provide another Report ID?
  • Report ID using the "default" profile that caused the issue: 916258297

    Report ID using the "test" profile: 37250788
  • Do you now see an install button for the Word plugin in the Cite → Word Processors pane of the Zotero preferences?

    Try the things here:
Sign In or Register to comment.