plugin crashes openoffice/ Report-ID: 962910902

The System: Linux OpenSuse 11.2, OpenOffice 3.11, Firefox 3.5.3, Sun Java 1.6.0_15

Inserting a bibliography into an OpenOffice document crashes OpenOffice immediately.
  • Oh, and that is what OpenOffice has to say about it when it crashes:

    QPixmap: It is not safe to use pixmaps outside the GUI thread
    QPixmap: It is not safe to use pixmaps outside the GUI thread
    QPixmap: It is not safe to use pixmaps outside the GUI thread
    QPainter::begin: Cannot paint on a null pixmap

    X-Error: BadDrawable (invalid Pixmap or Window parameter)
    Major opcode: 62 (X_CopyArea)
    Resource ID: 0x0
    Serial No: 26346 (26346)
    These errors are reported asynchronously,
    set environment variable SAL_SYNCHRONIZE to 1 to help debugging
  • This is actually quite annoying. Have to use mendeley untiil a solution comes up.
  • And this is the report-id:

  • edited October 4, 2009
    As far as I can tell, openSuSE 11.2 isn't released. OOo 3.0.0 under openSuSE 11.1 has worked perfectly in our testing, as has OOo 3.1.1 on other platforms. I'm going to install the latest 11.2 milestone in VMWare later today and see if I can figure out what's wrong, but it's quite possible that there's a bug in the package.
  • edited October 4, 2009
    This is a bug in the Qt VCL plug-in, which SuSE installs by default. It's also a problem under Karmic in Kubuntu, for any others on the bleeding edge. On SuSE, if you move the file /usr/lib/ooo3/basis3.1/program/ (/usr/lib/ooo3/basis3.1/program/ on a 64-bit system) to another directory, the problem is fixed, although OOo might look a little uglier for it.
  • You are right, OpenSuse 11.2 will only be released in November 2009. I am currently testing the release for potential use in our offices from January 2010 on. I have renamed the Qt VCL plug-in, and everything works like a charm again. Thanks!
  • arghhh.... the celebration was a bit premature. After moving /usr/lib64/ooo3/program/ to another directory, openoffice loses the ability to open, close or save (both, simple save and save as) files. Any attempt to initiate one of these actions results in an immediate crash.
  • fixed in OpenSuse 11.2 RC1. I don't know though whether this is a Suse-specific fix or if it is also been applied to Ubuntu Karmic.
  • dnh
    edited November 12, 2009
    Hello. I just updated to Kubuntu Karmic 9.10 and FF3.5 and here to, Openoffice crashes. It is indeed the bibliography that seems to cause the crash.
  • unfortunately, it is NOT fixed in OpenSuse 11.2 final. Inserting the bibliography still crashes Openoffice. So two major distributions currently seem to be a no-go
  • Temporary workaround: Removing renders Openoffice ugly, but apparently prevents it from crashing.
  • And let me add: One can change the button style in the preferences giving Openoffice an okay look, but obviously not giving the just introduced native kde look (which is what is supposed to do, I guess).
  • Hi,

    I'am using OpenOffice 3.1.1, too. I have the same problem with the crash when adding the bibliography.
    The Removing of (and kde4) does not work for me :-(. I also tried 3.1.99 (m2) from the unstable repositories. Here, the same problem occurs.

    @dnh: did you change/remove anything else as -kde?
  • The Zotero problem is KDE specific. If using Gnome Zotero works fine!
    See also:

    my temporary workaround is: use a Gnome session instead of KDE when working with Zotero.
  • Hi,

    now, in my case also the deletion of /usr/lib/ooo3/basis3.1/program/
    works :-)! For 64bit it's "/usr/lib64/ooo3/basis3.1/program/"

    I would never need Gnome again ;-).

  • I have the same problem with Kubuntu 9.10 and OOo 3.1.1.
    I tried to move out of the directory, and that seemed to work - but then I can't save etc.

    Any idea when the bug is solved?

  • Hi jeppeb,

    try to delete the OpenOffice KDE4 extensions (I deleted them in OpenSuse). I assume the KDE4 integration (Save, Load, Print...) will only work with the

    All the best

  • Openoffice still crashes when openoffice.ord-kde is installed ...
  • This will be fixed in OOo 3.2. Until then, there's nothing we can do about it (besides tell you to remove KDE integration).
  • Seems to work on Kubuntu 10.04 with OOo 3.2! :-)
Sign In or Register to comment.