Chrome Extension Not Saving to Application

When I try to save a PDF (for example) to Zotero using the chrome extension, I get the following error message: This item could not be saved because Zotero is not open or is unreachable. Please open Zotero and try again.

I've restarted the browser and tried again. I went to the following URL and got the "Zotero Connector Server is Available" message:

I tried all 5 steps listed under the first bullet point in this article:

Nothing worked. What's going on?
  • What's the URL?

    Can you save other pages (e.g., this forum page)?

    Can you provide a Debug ID from the Zotero Connector for loading the PDF and clicking save and getting that message?
  • I can't save this forum page. It says: Chrome extension not saving to application.

    But it is allowing me to save the PDF now. Not sure what changed.
  • edited August 25, 2021
    "Chrome extension not saving to application"? Are you quoting something or paraphrasing? That's not a message from Zotero. We always need exact messages.

    In any case, we'd need to see a Debug ID of something going wrong to tell you any more.
  • Ha! It is working now. "Chrome extension not saving to application" is the name of this webpage. :P Sorry for the confusion, but thanks for your help!
  • Oh! Yes, I see how that was confusing! Glad to hear it's working now.
Sign In or Register to comment.