Incorrect sort of one Bibliography item [Jurism]

edited 10 days ago
Most of my bibliography is sorted correctly on author surname when available or title when it is not. However, just the first and last items are out of order.

They are both items with no author and I checked that the author field is blank, not spaces.
I tried changing the titles but these items always appear first and last no matter what the title.
I tried adding dummy author names aaa,aaa to the one at the end and zzz,zzz to the one at the beginning. This also made no difference. So what on earth could they be sorting on?

Start of the Bibliography:
zzz, zzz, ‘Joseph Beuys: Ein Grüner im Museum’ [~ A Green in the Museum], Der Spiegel, 5 November 1979, 250–65

Abdullah, Hannah, ‘Kiefer and Beuys: Cathexis and Cartharsis [sic]’, ed. by Christian Weikop, Tate Papers, In Focus: Heroic Symbols 1969 by Anselm Kiefer [accessed 10 May 2021]

‘About the Scottish Cultural Heritage Consortium (SCHC)’, National Library of Scotland [accessed 10 May 2021]

[...]

End of the Bibliography:
[...]

Zumdick, Wolfgang, and Phillip Adams, Death Keeps Me Awake [Interview with Wolfgang Zumdick], Late Night Live, Australian Broadcasting Corporation (ABC) (South Bank Studio, London, 2013) [accessed 27 June 2020]

Zuschlag, Christoph, ‘Die Künstlergruppe “Zen 49” und ihre Stellung im Kunstgeschehene der Bundesrepublik Deutschland in den 1950er Jahren’ [The Artist Group ‘Zen 49’ and Its Position in the Art Scene of the Federal Republic of Germany in the 1950s], in Ersehnte Freiheit: Abstraktion in den 1950er Jahren [Freedom at Last: Abstraction in the 1950s], ed. by Manfred Großkinsky and Birgit Sander, 2017, pp. 71–81

aaa, aaa, ‘ARTtheses Forschungsdatabank fur Hochschulnachrichten Kunstgeschichte’ [ARTtheses Research Database for University Information, Art History], ARTtheses [accessed 10 May 2021]
Any ideas?
  • Which citation style are you using? (In case that has some sorting set.)
  • edited 13 days ago
    Sorry, should have said: MHRA3. I am using the Zotero standard template modified only to prevent capitalisation of titles. I don't see any options that I can set for sorting?

    The sorting is working fine for several hundred entries, just the first and last are wrong. they don't seem to be sorting on anything at all, and I cannot figure out why these particular two should have been selected for first and last. They look perfectly normal in the Jurism user interfcace. This only happened recently. Seems very odd.
  • I still have no idea why this is happening. I tried to solve the problem by re-creating the two items in question from scratch. This solved it for one of the two items, but not the other.

    I therefore ran refresh with debug turned on in the hope this would help you find the bug, but when I tried to submit it, I got the error 'invalid server response'. I tried to save it as a .htm file, but that did not work either... ! I notice that in the Help menu it says '0 items logged', even though there is plenty in the file - a series of javascript errors. I could only copy and save it as a .txt file. Can I send that to you?

    Report ID: 1623681667-19924
  • you can send the .txt file to support@zotero.org with a link to this thread
    If it's very large, zip it before sending.
  • I tried making a third version of the faulty item avoiding any copy and paste at all from the fields of the second version, and I did not insert the URL at all. The result was the same! I don't get it!

    I ran refresh with debug on again but unfortunately Jurism crashed before I could copy it. The log sent is of the first refresh.
  • I tried changing the item type from Magazine Article to Journal Article. No change.
  • That's the Beuys? I'd guess it's including the quotation marks in the sort -- the way the style is set up the title macro (rather than the title) ends up being used for sorting here. I'm surprised this doesn't come up more: it's possible citeproc handles different quotation marks differently here and (correctly) ignores double quotes and and (incorrectly imo) doesn't ignore single ones. If you're up for some experimentation, switch the file to US English and see what happens to sorting?
  • edited 10 days ago
    Yes, my Beuys thesis - four weeks until submission.

    No, the quotation mark is not included in the sort anywhere else, so the listing goes for example:
    Abdullah, Hannah, …
    ‘About the Scottish Cultural Heritage Consortium …
    ‘A l’Étranger’ [Abroad]…
    ‘abstract, v.’, OED Online …
    Adamson, Natalie…
    The offending item is
    ‘Joseph Beuys: Ein Grüner im Museum’ [~ A Green in the Museum], Der Spiegel, 33.45 (1979), 250–65
    ... which I expect to be listed under J.

    It was turning up at the top of the list. I played around changing the fields to try and discover which one is affecting the sort order, by inserting ZZZ at the front of the title, variant, and publication fields. It moved from the top to the bottom of the list, but when I took the ZZZ away it stayed there. When I added AAA it stayed there. I also tried changing or deleting the Jurism English variant of the title, but that made no difference either.
  • I tried deleting and re-inserting the citation, then it went to the top of the list again
  • @adamsmith
    Once again I changed each field, now one at a time with a refresh after each change, putting ZZZ in front of the Title, Variant title, Publication and even the page numbers in turn. This time it stayed resolutely at the top of the list.

    I again tried switching the type to Journal Article but all that does is reference by year, volume and issue instead of full date. Still at the top of the list.

    This is maddening because I cannot for the life of me see how this reference is any different from the hundreds of other references I have that are sorting correctly! Do you have any ideas at all?
  • Not really, no. If possible, I'd try what happens when you use regular Zotero on (a copy of) the same document.
    At this point my best guess would be some weirdness related to the multilingual fields, but who knows.
  • edited 10 days ago
    I realized the same problem recently, but I managed to solve it in my case. Some hints:
    1. First of all, make sure that the Jurism language settings are correct (Word processor integration: Set document preferences > Tab "Languages").
    This is often a little tricky when you work with multiple languages. Try different settings at "Sorting", because this seems to be the problem in your case. The Beuys item is being sorted under A, because your current "Sorting" setting seems to be for the translated text [A Green ...]. However, it needs to be set for sorting the original text (Joseph Beuys ...).
    BTW, you see the same (unwanted) behavior with the item "‘A l’Étranger’ [Abroad] ...". It is sorted by "Abroad", not by the original French title!

    2. Sometimes Jurism does not use this new "Sorting" setting immediately (This is the problem!). I managed to solve it by changing the translated title back and forth. Then refresh the bibliography, and the position of the item changes according to the new "Sorting" setting.
  • Yes! With Zotero instead of Jurism, the sort order is correct (but of course I then do not have the English variants of foreign titles). I guess I need to take it up with the Jurism people...
  • edited 10 days ago
    [Jurism]
    I just flagged "[Jurism]" in the title line to attract the attention of a Jurism developer...
    Summary of the problem so far:
    1. I have just one specific item of type Magazine Article that instead of appearing under J in the Bibliography appears at the top of the list or sometimes at the bottom:
      ‘Joseph Beuys: Ein Grüner im Museum’ [~ A Green in the Museum], Der Spiegel, 5 November 1979, 250–65
    2. I have hundreds of other Jurism items that sort correctly for MHRA3.
    3. I tried re-creating the item from scratch, typing each field by hand so that I would not copy any bad characters, but that made no difference
    4. I tried prefixing ZZZ to the title and variant fields, but that made no difference
    5. I tried deleting the title variant field, but that made no difference
    6. I tried changing the item type to Journal Article instead of Magazine article, but that made no difference
    7. However, if I refresh using the same document and the same database but running Zotero instead of Jurism, then the sort order is correct (but of course the English variants are missing).
    The problem therefore seems to be with Jurism. Apparently the sort is confused by this particular item, but I can't see why. It is maddening!

    I am four weeks away from submitting my PhD thesis and Jurism has become indispensable because I have several hundred bilingual titles, so a solution soonest would be most welcome! (My only alternative will be to unlink Jurism and edit the Bibliography by hand).
  • I really think that, in your case, the issue is just your "Sorting" setting. Please see my comment above, point 1.
    And it is not only the Beuys item, but also the ‘A l’Étranger’ [Abroad]… item that is not in the correct sort order. This supports my guess.
  • @bknorn Thanks for your responses (the first one popped up during my conversation with @adamsmith so I missed it at first).

    I don't really understand the Jurism sorting settings. I googled it but found a user guide that says a lot about transcribing japanese (not relevant) and recommends experimentation(!). What does the 'sort' column in the Language settings (for the document) actually mean?? I don't want to choose a language to sort on; I want to sort on the original, whatever that is.

    At the moment I have selected 'orig' for all the items in the top list and ticked 'lang' with square brackets for all of them too.

    In the lower list of languages I have ticked 'lang' for everything as they are all European languages and I do not use transcription. I have not ticked any 'sort' boxes because I want to sort on the original, not the translation.

    I fiddled a bit and repeated the refresh in the light of what you said, but so far no joy....

  • I also tried clicking the sort boxes for all languages. No difference.
  • edited 10 days ago
    @bknorn I looked in the rest of the Bibliography and found several examples of bilingual items with no author that are sorted correctly (many starting 'Joseph Beuys...'). Anyway, I already tried writing 'Joseph Beuys' in full instead of the tilde in the variant field [~ A Green in the Museum] but that did not change anything. So your theory that it is sorting on the English translation instead of the original title does not seem to be borne out...
  • I tried unticking the 'lang' boxes for all languages. That just removed the translations and did not change the sort order.
  • @bknorn ... so I do not think the sort settings are the problem?!?
  • edited 9 days ago
    Thank you for providing me with more details on the settings.
    This setup should work in your case:

    1. References in your Jurism database:
    (cf. https://juris-m.github.io/posts/2020-11-08-0.html#headline-field-language-settings)
    - Write the language code of the original title in the "Title" field into the "Language" field: (Joseph Beuys: Ein Grüner im Museum = de; A l’Étranger = fr; About the Scottish Cultural Heritage = en ...)
    - Add English variants to foreign titles: en = ~ A Green ... (The tilde does not matter)

    2. Jurism Word processor plugin, Document preferences, Tab "Languages":
    (cf. https://juris-m.readthedocs.io/en/latest/tutorial.html#multilingual-citations-in-an-english-article)
    - Titles: tick "primary: orig" and "[secondary]: lang" (in brackets)
    - below: tick "Translation/lang: English"
    - The sorting column is not relevant in your case. If you ticked "sort: English", the translated titles instead of the original titles would be used for sorting.
    - Refresh your bibliography. If any item is not in the right place in your bibliography, change the English variant in the database (add or delete one character), refresh your bibliography again. This seems to be a bug as mentioned above (https://forums.zotero.org/discussion/comment/385242/#Comment_385242, No. 2). But changing the title in the database triggers the bibliography to correct the sort order.

    Good luck!
  • @bknorn Many, many thanks for your patience, detailed explanations and pointers to resources. This has finally fixed it. The error seems to be that I had ticked 'en' in the sort column of the document preferences (though not in Jurism preferences, which I presume are a sort of default for the document preferences?).

    This does not entirely explain all my trials where I changed the variant title and inserted an author without effect, but I am not inclined to spend more time on this now.

    The most confusing part is the lower set of boxes on the preferences screen as there is no title to indicate what they are for. None of the resources explains this very clearly. I assume that ticking the 'lang/en' box tells Jurism that the main language of the document is English? So why are there several boxes rather than a set of radio buttons? You said that ticking the 'sort/en' box would cause it to sort on the English translations rather than the original but why one would tick to sort on any other language is unclear — surely the only useful options are 'original' or 'selected translation'?

    Anyway, 'lang/en' is now the only box ticked in the lower segment of the screen and that seems to have fixed the problem.

    Thanks again :-)

Sign In or Register to comment.