Forced Capitalization in Chicago Style

I'm doing a book project with many transliterated titles, mostly in Hebrew. They need to appear in lower case but Chicago style forces them into capitals. I can see I need to edit the style but I'm worried about ruining the code. Has anyone ever done this? Can you send me the edits you made?
  • Which Chicago style are you using? Then we can suggest the edits you'd need to make.
  • edited 20 days ago
    @yosefa No need to edit the style, just put "Hebrew" in the Language field
  • @damnation I'm using Chicago 17th edition full note, thanks!
  • @erazlogo
    I don't need the note in Hebrew, but rather transliterated. If I change it to Hebrew, it changes all the prepositions (like "and" and trans." and et al) to Hebrew letters and I don't want that, so for example here is the note I need:

    Michael Gluzman, Hanan Hever, and Dan Miron, Be-`ir ha-haregah: biḳur meuḥar [In the city of slaughter: a visit at twilight] (Tel Aviv: Resling, 2005), 9.

    And here is what I get on Zotero:

    Michael Gluzman, Hanan Hever, and Dan Miron, Be-`ir Ha-Haregah: Biḳur Meuḥar [In the City of Slaughter: A Visit at Twilight] (Tel Aviv: Resling, 2005), 9.
  • So, "text-case="title"" is what sets this in the style.
    In chicago fullnote you'd take this out of the title-note and/or title macros that you find in lines 236 onwards.
    If you want it removed just for books then you would remove that from the conditionals that test for books like such "<else-if type="book graphic motion_picture song" match="any">"

    General instructions here: https://www.zotero.org/support/dev/citation_styles/style_editing_step-by-step

    Please read carefully and make sure to edit ID/self link accordingly.
  • edited 20 days ago
    If you enter “he” in the item’s language field, that will disable an title casing for the item, no need to edit the style.
  • edited 20 days ago
    @yosefa This is what I get with Language=Hebrew:

    Michael Gluzman, Hanan Hever, and Dan Miron, Be-`ir ha-haregah: biḳur meuḥar [In the city of slaughter: a visit at twilight] (Tel Aviv: Resling, 2005).

    As you can see, "and" is still there. I think this will only change if you change the entire Zotero interface to Hebrew.
  • To clarify -- while both of these will work, what bwiernik suggests has the advantage of allowing you to keep English titles in sentence case, which will make them work for other styles, and it won't affect the language of the citations (that's when you set the style itself to Hebrew)
Sign In or Register to comment.