Annotation issues in Zotero PDF Reader

Hi all,

I'm really enjoying the new features in Zotero lately, particularly the ability to read, highlight, and add annotations from within Zotero, but I've noticed two small issues:

1. Highlighting and then adding highlights as annotations results in each annotation adding a space after the annotation and before the quote, e.g. "....the study showed the results were significant at the p > .5 level. " (citation). Notice the space after "level." and before the quotes. Not a huge deal. Might even be due to my heavy hand when highlighting, but it seems to be pretty consistent across my annotations.

2. Zotero does not respect Page Labels. I like to add Page Labels to most PDFs to accurately reflect the actual page numbers (not Page 1, 2, 3, but the pages according to the journal). After adding these, Zotero still extracts annotations according to Page 1, 2, and 3, not the page labels. Zotfile extracts annotations according to the Page Labels; would it be possible to get this fixed in the Zotero extractions?

Thanks!
  • edited 20 days ago
    1) We will fix that.
    2) Zotero PDF reader tries to extract page label directly from page text or use the already assigned page labels, and only then falls back to page index (1,2,3). If that doesn't work, could you provide an example PDF where the issue appears? If so, you can send it to support@zotero.org also referencing this thread.
  • I've emailed a copy of the PDF in question to support@zotero.org

    I deleted the Extracted Annotations note. Then I manually went through the annotations in the left-hand panel and changed the page numbers to be accurate. Now when I try to add an item note from the annotations, Zotero simply creates a blank note. I can see my annotations in the left-hand panel, but Zotero doesn't pull them into a note. Is that because I deleted the previous note?

    Debug ID: D1893154604
  • Thanks for sending the PDF. We'll take a look at the page label issue.
    Now when I try to add an item note from the annotations, Zotero simply creates a blank note.
    That's already fixed in the latest beta.
  • Yep, saw that in another thread. Had to update Zotero, and it's working again. The page labels also seem to have been fixed/sorted themselves out.

    Great work! Thanks!
  • Actually, the issue nr. 2 still appears in some circumstances, but it will be fixed in the next update.
Sign In or Register to comment.