[Solved] How to run set_launcher_icon the right way?

edited 9 days ago
Dear fellow users of Zotero,

tldr/solution: In my case the launcher ~/.local/share/applications/zotero.desktop was broken. After deleting the launcher (manually), and redoing ln -s /opt/zotero/zotero.desktop ~/.local/share/applications/zotero.desktop, the launcher is set properly...

Recently I did a fresh install of Mint 20.1 and installed Zotero according to your own guideline (tar > /opt/zotero). Thus I have to run `set_launcher_icon` but as a nontechny newbie I fail to do so. Before I mess anything up, I decided to ask for help.

After downloading it manually form your website, I ran the followings to install Zotero and set the icons according to your guideline:

cd ~/Downloads
sudo mkdir /opt/zotero
sudo tar -xvf Zotero-5.0.96_linux-x86_64.tar.bz2 -C /opt/
(copy the files from /Zotero-5.0.96 to /zotero manually, because I still do not know how to rename the extracted folder)
cd /opt/zotero

But I am stuck on how to run set_launcher_icon. Neither (sudo) sh ./set_launcher_icon, nor (sudo) bash ./set_launcher_icon are succesful. They results either in set_launcher_icon: 7: Bad substitution, or nothing.

Thus how do I successful run the set_launcher_icon file to setup the icons?
  • If you're not comfortable on the command line, I would recommend just using the zotero-deb package, assuming it works on your system.
  • Thanks @dstillermann, iff I am "not comfortable on the command line", then I would stay with Windows. But here I am on Linux and hoping to learn how to use the command line properly.

    Thus I would like to ask again, "how do I successful run the set_launcher_icon file to setup the icons?"
  • It's a shell script. You run it like any other shell script. Again, if you don't know how to do all of this, you should use the zotero-deb package.
  • If zotero-deb does not work that's something I'd want to look into.
  • edited 9 days ago
    Hum, then what I did whas right, right? But I still have no icon in the menus.

    I did the following to try to get a launcher in the start menu, but with no positive result:
    computer:~$ cd /opt/zotero
    computer:/opt/zotero$ bash set_launcher_icon
    /opt/zotero/zotero.desktop is not writable

    computer:/opt/zotero$ sudo bash set_launcher_icon

    computer:/opt/zotero$ sudo bash set_launcher_icon.sh
    bash: set_launcher_icon.sh: No such file or directory

    computer:/opt/zotero$ ./set_launcher_icon
    /opt/zotero/zotero.desktop is not writable

    computer:/opt/zotero$ sudo ./set_launcher_icon

    computer:/opt/zotero$ sudo su
    computer:/opt/zotero# ./set_launcher_icon

    Even the following does not work:
    computer:~$ zotero
    zotero: command not found

    Edit: It seem that what I did was indeed according to your guidelines, but in my case the launcher ~/.local/share/applications/zotero.desktop was broken. Thus I deleted it manually and redid it, with positive results. Zotero is now indeed in the launcher...
Sign In or Register to comment.