Zotero Connector JSTOR issue

Hello,

My Zotero Connector does not save pdf's from JSTOR. I use Chrome on a Mac. Chrome, Zotero, all up to date. Account provided from my University to all these things. Yes, I am aware of the common trick regarding JSTOR (ie. clicking “OK” to the terms and conditions) - I did that. The problem is NOT a RED error on the PDF saving process. The problem is having absolutely NO PDF saving process. Zotero only saves the reference. It is as if the saving pdf option has disappeared entirely.

1. https://www.jstor.org/stable/j.ctv12pnt9c.15?refreqid=excelsior:d823cd0a0dc39262825f171fbeefb50e&seq=1#metadata_info_tab_contents

(I also tried through other links and didn't work)

2. Report ID: 1386816221

3. "Saving to my Library" - accompanied by an icon with an open book. Just this. No PDF line, no PDF error line. Just nothing.

4. "Save to Zotero (JSTOR) Has access to this site"

Thanks!
  • This looks like it happens for book chapters but not for journal articles -- does that sound like what you're seeing? E.g. the PDF here imports fine for me: https://www.jstor.org/stable/42855774
    But the one from the chapter you link to doesn't.
  • edited 12 days ago
    Thanks for your response. Indeed, the pdf from the link you provided works for me as well. The pdf I tried to import is a book chapter. I did not have this issue previously. Last time I imported a book chapter was on July 2020. I wonder whether something changed in the meantime. Is there anything I can do to avoid the manual download (and subsequent upload to zotero)?
  • Nothing on your end, no. I've created a ticket to track this:
    https://github.com/zotero/translators/issues/2261
    Nothing changed on our end, so pretty sure that'd be a JSTOR change causing this.
  • Hi @adamsmith did you have any updates? I checked this ticket link, but I have to be very honest - didn't get what was going on! Thanks again for your response and attention to this problem!
  • Yeah, this should work now
Sign In or Register to comment.