Zotero experienced an error updating your document.

"Zotero experienced an error updating your document.

Would you like to view troubleshooting instructions? "

This is the error message I'm getting while I try to add the citations or references to my word documents. Regardless if the word document either already has citations or new Microsoft word document. Could anyone help me resolve this ASAP?

Thank you,
«1
  • Can you provide a Report ID?

    What exact, full version of Word?
  • Microsoft 365 MSo (16.0.13127.20402) is word version.

    This is the report ID: 1178985001
  • There are no errors in that report. Did you submit that after getting an error, and before restarting Zotero?
  • this is report Id 1575976123 after getting the error.
  • [JavaScript Error: "An unhandled exception occured. [getDocument:\vboxsvr\adomas\zotero\word-for-windows-integration\build\zoterowinwordintegration\document.cpp]"]
    And this happens in a completely new, empty document?

    @adomasven will need to take a look.
  • Yes both new (empty) and adding citations in pre-exisiting document.
  • Are you storing your document in OneDrive? Does Zotero work if you change the document name to not include any space " " characters? Does Zotero work if you store the document on the local disk?
  • I'm storing them in local disk and Zotero does not work even if I change the document name without including space.
  • Could you produce a Debug ID from Zotero?

    1. In the Zotero Help menu, go to Debug Output Logging and select Enable.
    2. In Word press the Add/Edit Citation button in the Zotero tab.
    3. Before doing anything else, return to Zotero Help → Debug Output Logging and click Submit Output, which will disable logging and submit the output to zotero.org. A window should pop up containing a Debug ID. Click “Copy to Clipboard” and paste the Debug ID into this forum thread.
  • This is the debug ID: D2008703398
  • Did you recently start using some security software? Have you tried disabling it? Have you tried restarting your computer?
  • Not really I have been using bit defender for a year and zotero used to work but I can't find a reason for zotero not to work. I use bit defender total security and bit defender agent, do you think agent might cause any issues?
  • An update to those could have introduced an issue. Have you tried disabling it? Restarting the computer?
  • I tried like you said, its not working having the same issues.
  • Does it work if you run both Word and Zotero as administrator? This is just a troubleshooting step, not a fix.
  • Word and zotero is working when being runned as administrator.
  • Why does this happen ? when not run by administrator.
  • You should verify that when you run them normally neither is running as administrator. This could potentially happen if one was running as administrator and the other wasn't.
  • Looks like I should run them both as administrator every time.
  • edited October 7, 2020
    No, you shouldn't. Running programs as administrator is a security risk.
  • When I don't run them as administrator I get the same issue. So, what do you think could be done on this?
  • I'm saying that you should first confirm that neither is actually running as administrator:

    https://superuser.com/questions/1213101/check-if-an-app-is-running-as-admin
  • Both are actually running as administrator.
  • Are you referring to the Elevated column, as explained there? You need to make sure neither says Yes.
  • Yes, I followed the link which was posted above and both word and zotero are running as administrator.
  • OK, so then fix it so they're not.
  • I'm sorry, word has "yes" but zotero has "no".
  • OK, right, that's what I've been trying to explain. You need to make sure neither is running as administrator. Check the Properties pane for the Word executable.
  • How do I change that ?
  • As I say, you can check the Properties pane for the Word executable, or for the shortcut, but there are various other ways this could be set, and we can't provide general Windows support here, so you'll need to do a web search for more information or ask in a Windows forum. This isn't a Zotero issue.
Sign In or Register to comment.